3

I use to have my SMS displayed in the macOS Messages app but it doesn't work anymore.

I check this Apple support document and my configuration is well set up:

Any idea how to restore it?

My configuration:

  • iOS version: 11.2.6
  • macOS version: Sierra 10.12.6
  • What version of macOS? What have you already tried to fix the problem yourself? – fsb Mar 12 '18 at 12:54
  • iOS: 11.2.6, OSX: 10.12.6. I checked everything was set up here: support.apple.com/en-us/HT202549 – Martin Delille Mar 12 '18 at 13:00
  • Did you try disabling and enabling iMessage? – Pratik Mar 12 '18 at 16:21
  • yes without success – Martin Delille Mar 13 '18 at 12:52
6

For SMS to appear in Messages app in macOS, you need to have Text Message Forwarding turned on in your iPhone. It can be enabled by going to Settings apps → Messages → Text Message Forwarding on your iPhone and turning on the switch which appears against your macOS device in the list.

The iMessage app on iPhone can send both an iMessage message as well as a SMS. iMessage appear in a blue bubble, while regular SMS appear in a green bubble.

Assuming you are signed into both your iPhone 6 and iPad 2nd generation, you can receive and reply to regular SMS (green bubble) from your iPad (as well as other Mac and iOS devices signed in using the same Apple ID), by using a feature called Text Message Forwarding. The option can be found by going to Settings apps → Messages → Text Message Forwarding and turning on the switch which appears against your iPad device in the list.

For step by step instructions, you can go through the Apple knowledge base articles, Use Continuity to connect your Mac, iPhone, iPad, iPod touch, and Apple Watch and How to forward SMS/MMS texts on your iPhone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .