After choosing a file location to save a screen recording, the movie will start to save, then it says "Cannot Open" and nothing is saved. I can retry but it still doesn't. I just saved a video before this. It's on macOS High Sierra. 10.13.1. This same issue is plastered all over the Apple.com help forums but there are no answers.

QuickTime is Version 10.4 (928.5.1) - the version that came with my MacBook Pro (15-inch, 2016).

After the saving progress bar gets to about 1/4, it flashes "cannot open this media may be damaged quicktime" then "Cannot Open"

I'll add a video below to show exactly what

To debug, I did confirm that a 5 second video with voiceover could save. However, a 25 minute video will not. I closed that video and recorded another screen recording for 10 minutes long and same issue. In the past I've been able to record 10-30 minute videos and save. Now it only allows small videos.

enter image description here

Video of what happens: https://www.youtube.com/watch?v=DBME45Ks3_o

enter image description here

  • 1
    How much space is left on your hard drive?
    – daviewales
    Commented Mar 10, 2018 at 22:29
  • @daviewales 100GB
    – User
    Commented Mar 10, 2018 at 22:38
  • 1
    Well it's not that then!
    – daviewales
    Commented Mar 11, 2018 at 23:04
  • 1
    This is a bit of a longshot, but there are a couple of things you can try to isolate issues like this. Try starting in 'Safe Mode', by holding down Shift-S on boot. This disables unnecessary kernel extensions, and a few other things. Then try the screen recording. If it works in Safe Mode, but not in normal mode, then we can start to do some investigation to find the problem. If that doesn't work, try creating a new user account on your Mac, and see if the screen recording works in the other account.
    – daviewales
    Commented Mar 11, 2018 at 23:12
  • Did you manage to try my answer? Commented Mar 20, 2018 at 10:21

4 Answers 4


Sounds like a permissions problem. If it’s a bug I suspect it will be fixed in a future macOS update. Not much help, I know.

Until then, you have to peek behind the curtain:

  1. Unsaved recordings are stored at ~/Library/Containers/com.apple.QuickTimePlayerX/Data/Library/Autosave Information/
  2. The file will be called Unsaved QuickTime Player Document.qtpxcomposition, or similar
  3. Show Package Contents on that file
  4. Inside is Screen Recording.mov which you can copy and keep

enter image description here

  • 4
    I was able to "save" the recording using this trick however whenever I try to open or convert the MOV file from the package it throws errors. I've tried QuickTime, iMovie, VLC, Adobe Media Encoder...while I can play the MOV without issue in Quicktime, I can't use it anywhere without things exploding. This makes me think maybe the reason it couldn't save is that there is something in the file data or the file headers that's gone sideways. Commented May 25, 2018 at 3:16
  • 2
    Haven't really tested it or what might've triggered it; pretty salty about it and already spent hours just trying to recover things. I was able to rename the MOV file to use an AVI extension and open the AVI in QuickTime, let it "convert", save as MOV and it worked minus the last ten minutes which are missing video but have audio. I think somehow the video got corrupt, but again haven't tested. Commented May 25, 2018 at 18:15
  • 2
    Thank you so much for the answer. It works great. Saved me a lot of hassle.
    – user7672
    Commented Jul 8, 2018 at 4:28
  • 6
    Thanks, @MattSephton! You saved me from a certain heart attack.
    – smozgur
    Commented Feb 18, 2019 at 20:37
  • 2
    @MattSephton You should be given a million points for this. Commented Dec 10, 2019 at 0:08

Had this situation now, couldn't locate the temporary file in the suggested places - however:

Doing Menus:

File/Move To... - did the trick, to the ~/Documents folder


I've got a friend who had a similar sounding problem. In his case it was Docker could not write to a temporary location. He had tried the permissions repair a couple different ways.

He was able to resolve his problem using a bit of what I call Apple Black Magic which is resetting your NVRAM and resetting your SMC, which seems to have influence over features you would have never thought were associated.

These two seemingly unrelated resets, seems to resolve many IO based bugs.


I succeeded to save the file using HandBrake.

As a shortcut I was running the following command in the Terminal to create a simlink into ~/Downloads:

ln ~/Library/Containers/com.apple.QuickTimePlayerX/Data/Library/Autosave\ Information/Unsaved\ QuickTime\ Player\ Document.qtpxcomposition/Movie\ Recording.mov ~/Downloads/rec.mov

Then I used HandBrake to create a lower resolution export. The shortcut saves the need to navigate into this complicated original location. When export is finished, the simlink should be deleted (e.g. rm ~/Downloads/rec.mov)

Warning: be careful not to exit QuickTime before you are finishing the export!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .