22

After choosing a file location to save a screen recording, the movie will start to save, then it says "Cannot Open" and nothing is saved. I can retry but it still doesn't. I just saved a video before this. It's on macOS High Sierra. 10.13.1. This same issue is plastered all over the Apple.com help forums but there are no answers.

QuickTime is Version 10.4 (928.5.1) - the version that came with my MacBook Pro (15-inch, 2016).

After the saving progress bar gets to about 1/4, it flashes "cannot open this media may be damaged quicktime" then "Cannot Open"

I'll add a video below to show exactly what

To debug, I did confirm that a 5 second video with voiceover could save. However, a 25 minute video will not. I closed that video and recorded another screen recording for 10 minutes long and same issue. In the past I've been able to record 10-30 minute videos and save. Now it only allows small videos.

enter image description here

Video of what happens: https://www.youtube.com/watch?v=DBME45Ks3_o

enter image description here

  • 1
    How much space is left on your hard drive? – daviewales Mar 10 '18 at 22:29
  • @daviewales 100GB – User Mar 10 '18 at 22:38
  • 1
    Well it's not that then! – daviewales Mar 11 '18 at 23:04
  • 1
    This is a bit of a longshot, but there are a couple of things you can try to isolate issues like this. Try starting in 'Safe Mode', by holding down Shift-S on boot. This disables unnecessary kernel extensions, and a few other things. Then try the screen recording. If it works in Safe Mode, but not in normal mode, then we can start to do some investigation to find the problem. If that doesn't work, try creating a new user account on your Mac, and see if the screen recording works in the other account. – daviewales Mar 11 '18 at 23:12
  • Did you manage to try my answer? – Matt Sephton Mar 20 '18 at 10:21
39
+25

Sounds like a permissions problem. If it’s a bug I suspect it will be fixed in a future macOS update. Not much help, I know.

Until then, you have to peek behind the curtain:

  1. Unsaved recordings are stored at ~/Library/Containers/com.apple.QuickTimePlayerX/Data/Library/Autosave Information/
  2. The file will be called Unsaved QuickTime Player Document.qtpxcomposition, or similar
  3. Show Package Contents on that file
  4. Inside is Screen Recording.mov which you can copy and keep

enter image description here

  • 2
    I was able to "save" the recording using this trick however whenever I try to open or convert the MOV file from the package it throws errors. I've tried QuickTime, iMovie, VLC, Adobe Media Encoder...while I can play the MOV without issue in Quicktime, I can't use it anywhere without things exploding. This makes me think maybe the reason it couldn't save is that there is something in the file data or the file headers that's gone sideways. – Michael Thompson May 25 '18 at 3:16
  • 1
    I've never encountered that before. Can you reproduce it consistently with new, unsaved screen recordings? – Matt Sephton May 25 '18 at 8:20
  • 1
    Haven't really tested it or what might've triggered it; pretty salty about it and already spent hours just trying to recover things. I was able to rename the MOV file to use an AVI extension and open the AVI in QuickTime, let it "convert", save as MOV and it worked minus the last ten minutes which are missing video but have audio. I think somehow the video got corrupt, but again haven't tested. – Michael Thompson May 25 '18 at 18:15
  • 1
    Thank you so much for the answer. It works great. Saved me a lot of hassle. – user7672 Jul 8 '18 at 4:28
  • 1
    Thanks, @MattSephton! You saved me from a certain heart attack. – smozgur Feb 18 at 20:37
0

I've got a friend who had a similar sounding problem. In his case it was Docker could not write to a temporary location. He had tried the permissions repair a couple different ways.

He was able to resolve his problem using a bit of what I call Apple Black Magic which is resetting your NVRAM and resetting your SMC, which seems to have influence over features you would have never thought were associated.

These two seemingly unrelated resets, seems to resolve many IO based bugs.

You must log in to answer this question.

protected by Community May 22 '18 at 16:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .