0

I am using macOS Server to host files on a website. I often need to download large files to the server to host them myself. Because I do not usually have physical access to the server, I use the default Screen Sharing app In macOS from a different mac into the server (VNC). From there I open Safari (on the server) enter the url and start the download. The files range from 400MB to 2GB. They are downloaded to an external drive that is constantly plugged into the Mac. Once the download starts it can take a while to complete so I often disconnect through the screen sharing. Unfortunately, a minute or two after I disconnect the download stops. When I check what happened by clicking on the download arrow in Safari it says that the download timed out. If I try to continue the download, it continues only to be stopped again when I quit the screen sharing. This is extremely frustrating as I am forced to keep the connection open while it is downloading.

My settings in the Energy Saving tab of System Preferences are as follows.

Computer Sleep: Never

Display Sleep: 5 Minutes

Put Hard Drives to Sleep when possible: Checked

Wake for Network Access: Checked

-

Schedule

Start up or wake: Every day at 6:30 AM

Sleep: Every Dat at 12:00 AM

Note: The downloads are NOT taking place between 12:00 AM and 6:30 AM

Thanks!

  • Is there a reason you don’t use the Server as a file server instead of a web server? Also, which Mac is set to put the hard drives to sleep, the server, or the machine connecting to the server? – IconDaemon Mar 9 '18 at 0:23
  • Server is set to put hard drives to sleep when possible. It is used as a file server and a web server. But it does not have any effect on safari downloads I don't think. P.S. Thanks for the edits. – JBis Mar 9 '18 at 1:05
  • As an experiment, I’d try setting the drives not to sleep and try file sharing instead of serving the files over http. – IconDaemon Mar 9 '18 at 22:35
  • I'll try setting the drives not to sleep. But why would http vs file sharing have anything to do with it. – JBis Mar 10 '18 at 23:43
  • Not sure why. Just a troubleshooting step to see if the behavior changes. – IconDaemon Mar 10 '18 at 23:54
0

Could not figure out why this was happening but using the caffeinate command I was able to fix it.

https://developer.apple.com/legacy/library/documentation/Darwin/Reference/ManPages/man8/caffeinate.8.html

I ended up just created a LaunchDaeomon to run it at certain times.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .