My iMac has a 2 TB Fusion Drive. Our PC IT guy seems to screwed it up. Now I only have 1 TB of usable space. I tried formatting, repartitioning, but nothing works to gain that 1 TB back.

I don't need the data in it as this is a new iMac.

enter image description here

enter image description here

  • 1
    Please add the output of sudo gpt -r show diskX (with X=0 and 1), diskutil list and diskutil cs list entered in Terminal.app to your question! Don't add it as comment!
    – klanomath
    Mar 7, 2018 at 11:14

2 Answers 2


It seems that you have only one partition of 1 TB. What you need to do is :

  • Select "Fusion Drive"
  • Click on "Partition" button
  • Set a partition of 2 TB

I don't have my MacBook so I can't make you some screenshots, but setting new partition should show you your all disk.

But on your second screenshot, I can see that the Untitled part is 2.12 TB. Did you tried to proceed to the install of macOS and then see if everything is all good ?


A similar thing happened to me recently. Follow what Chris said, if it works, that is fine! If not, make sure you have backed up all your necessary files into a separate storage. And try formatting the whole drive, you should be able to re-create the partitions and use full 2 TB and then re-install MacOS.

That's what worked for me. It gave me a headache. :/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .