2

I have to administrate a remote macos machine. Today I logged in since some time off and I've got this error:

   $ make

  dyld: Library not loaded: @rpath/DVTFoundation.framework/Versions/A/DVTFoundation
      Referenced from: /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild
      Reason: no suitable image found.  Did find:
        /Applications/Xcode.app/Contents/Developer/usr/bin/../../../SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation: cannot load '/Applications/Xcode.app/Contents/Developer/usr/bin/../../../SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation' because Objective-C garbage collection is not supported
    Please review and agree to the software license agreements!

Amy idea what this is about?

I've already installed Xcode (macOS Sierra version 10.12).

Can it be caused by the Sierra upgrade? Since I've installed Xcode under the previous version (Lion), and now it's broken?

It seems odd since I've installed Xcode Sierra version.

Update:

Apparently the error is triggered every time I use some Xcode tool, for instance accepting the license via cli triggers the exact same error.

I have not already had access to the machine directly, but I'll try to reinstall all Xcode building tools.

2
+25

That is an odd error as the framework request in question is coming from an Apple app.

It seems your Xcode has been updated to a newer version and the licence agreement needs to be accepted. You can do this two ways:

  1. Open Xcode.app and follow the prompts
  2. In Terminal: sudo xcodebuild -license
    (and with newer versions sudo xcodebuild -license accept to do it in one step)

Afterwards confirm xcode-select --print-path returns a valid result.

You should then be good to go, assuming your combination of macOS version and Xcode version are compatible.

  • Unfortunately accepting the license via command line triggers the exact same error! – LotoLo Apr 3 '18 at 9:33
0

I believe garbage collection is no longer supported. You'll need to transition your code to use ARC or manual retain/release.

  • 1
    It's not the OP's code but rather Apple's xcodebuild that is calling the framework in question, at least according to his error message. – Matt Sephton Mar 31 '18 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .