So I replaced my broken HDD with a new SSD on my 2011 13" Macbook Pro with 10.7.5 being the stock OS, and I want to install Mac OS X High Sierra 10.13.3 on it. Please note that direct update from 10.7.x to 10.13.x is not possible.

First I went to recovery mode, installed Lion, downloaded El Capitan 10.11.6 via Mac Store and tried updating it but it failed. The log looks mostly clean, the only error I see is:

failed to update bookmark for item (null) [UUID]

Then I tried to boot in recovery mode again and I saw that El Capitan's recovery took over, I erased the disk and went with Reinstall MacOS option, and everything went well, downloaded High Sierra 10.13.3 from Mac Store and decided I should do a clean install so I created a bootable USB with createinstallmedia command but the installation hangs when the progress bar reaches %100.

  • Is there a way to see what the OS installation is doing? --I only see an Apple logo with a progress bar below it, some said they see an ETA during installation but I don't see anything else than what was described.

At this point I had to redo all the steps all the way up to installing El Capitan, after I downloaded High Sierra again I opened the .app installation and High Sierra installed fine.

  • Why can't my Macbook Pro handle a clean installation of High Sierra?

  • It's been too much trial and error for me the past 3 days, and you could make things so much easier for me if you answer this as well, I tried to Restore using Disk Utility with InstallESD.dmg being the source and a USB stick the destination in order to create a bootable Mac OS installer, but the problem is, it's not bootable! How can I fix that?

Side note: InstallESD.dmg was taken from /Applications/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport/InstallESD.dmg

  • Do I have to erase the SSD before I do a clean install? Because that's not possible since the recovery partition resides on the SSD, I can only erase the partition which in the previous Mac was installed on. If I need to do that, how can I unmount it properly?
  • 1
    Shouldn't the question rather be: "how much do I trust the website I've downloaded the non-official copy of 10.13.2 from"?
    – nohillside
    Commented Mar 6, 2018 at 13:33
  • @patrix no! because I need to know if updating from an old OS to the latest is wise or not, in fact let's pretend that the non-official copy is safe, How would install-update-update would be different to a clean install?
    – Shayan
    Commented Mar 6, 2018 at 13:36
  • You might save some time going directly to 10.13 and then using the migration utility to then copy your files and apps. But that is about all you would save, some time. Commented Mar 6, 2018 at 13:56
  • Did you replace the optical drive with a HDD or SSD? I ask because if you have an internal HDD and internal SSD, then this would change how you APFS format the internal drives. Commented Mar 6, 2018 at 14:46
  • 2
    Possible duplicate of Can Recovery Mode install OS X onto a blank SSD?
    – Allan
    Commented Mar 6, 2018 at 16:07

1 Answer 1


Note: These instructions assume that the only internal drive is a SSD.

The procedure given below may seem lengthy, but once completed, you will not have to preform this procedure again. After installing 10.13.3, you will be able to reinstall the current version of macOS directly from Internet Recovery.

  1. Boot to Internet Recovery
  2. Use the Disk Utility app to erase the SSD. Choose for Mac OS Extended (Journaled) for the format.
  3. Install 10.7.5.
  4. Boot to 10.7.5.
  5. Download 10.13.3 installer app from the App Store. If this is not possible, then first upgrade to 10.11.6.
  6. Transfer the 10.13.3 installer app to a USB flash drive.
  7. Boot from the flash drive.
  8. Use the Disk Utility app to erase the SSD. Choose APFS or APFS (Encrypted) for the format.
  9. Install 10.13.3
  10. Boot to 10.13.3
  • I did everything all the way up to step 9, But the installation of High Sierra just hangs when the status bar is full (reaches 100%), it's been hours on top of hours and it just hangs there, I'm starting to think, since App store did not let me download High Sierra from 10.7.5 and had me install 10.11.6 first then update to 10.13.3 does that mean a direct install to 10.13.3 is not possible for my Mac? I've tried so many different workarounds for installation hanging that I found on the internet, could this be the fact that I can't do a clean install of 10.13.3 on a 2011,13'Mac?
    – Shayan
    Commented Mar 7, 2018 at 21:59
  • Did you try Mac OS Extended (Journaled) or Mac OS Extended (Journaled, Encrypted) instead of APFS or APFS (Encrypted)? Your Mac requires a firmware update for APFS to work. It is possible this update does not occur until after High Sierra is installed. This would account for why your installation hangs. I would suggest try to installing using one of the legacy Mac OS Extended formats. Commented Mar 8, 2018 at 23:28

Not the answer you're looking for? Browse other questions tagged .