4

I used to love shift+control+command+4 for pasting screen grabs. But now it doesn't work in Chrome.

In Stickies and Text Edit it doesn't work and gives the Apple error sound.

The pasting Works fine in Discord, Skype and Firefox.

I'm using macOS High Sierra 10.13.4, copy paste image doesn't work in Safari either.

This is a real productivity killer.

  • Let's have a little more information, please. What version of macOS are you running? What version of Chrome? How many applications have you tried the key command in and for what result? What have you tried to fix the problem? – Tony Williams Mar 6 '18 at 0:44
  • I'm seeing the same behavior in Notes. I can see that the clipboard has an image in it, but trying to paste it gives an error sound. A workaround is to drop the ctrl from the key-combo and you'll get an image on your desktop then you can just drag that wherever you want an image. – dwightk Apr 5 '18 at 13:33
  • What version of macOS High Sierra are you using? – user3439894 Apr 5 '18 at 14:44
  • 2
    Can't replicate. macOS 10.13.4, screen grab copied to clipboard via cmd-shift-ctrl-4 can be pasted from/to any app I am testing (including Chrome). – dr.nixon Apr 5 '18 at 19:01
2
+25

I've seen this kind of behaviour with other functionality, try the following command in Terminal (may require sudo)

Change directory to "/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/"

cd /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/

./lsregister -kill -seed

OR

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed

This rebuilds the launch services database, sometimes corruption in this can cause weird behaviour


EDIT: Since the above didn't help let's try something else. When you use shift+control+command+4 to copy a section of the screen to the clipboard you can view the clipboard contents. To do so, switch to Finder and click Edit > Show Clipboard to show the contents of the clipboard. You should see something like this window pop up that says "Clipboard" at the top and has a description of the clipboard contents in the bottom-left corner. Do you get the same thing?

clipboard

  • thx, but I get lsregister: command not found – SuperUberDuper Apr 12 '18 at 9:24
  • Sorry, I had it on my path from before :) Updated the instructions – conorgriffin Apr 12 '18 at 9:27
  • no luck with either im afraid – SuperUberDuper Apr 12 '18 at 9:39
  • Do you mean it didn't help or you couldn't execute lsregister? – conorgriffin Apr 12 '18 at 9:40
  • it didnt help unfortunately – SuperUberDuper Apr 12 '18 at 9:42
0

Since replicating this problem on other systems running macOS High Sierra 10.13.4 has proven difficult, it's probably worth starting with some basics to see if we can resolve or narrow down the problem.

Your question doesn't actually state what you've already tried (if anything) to resolve this, so perhaps you could start by booting into Safe Mode to see if that makes any difference.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does shift+control+command+4 work for pasting screen grabs?)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Test again

Once you've booted into Safe Mode, let me know how you went and we'll go from there.

Reset NVRAM

Okay, since booting into Safe Mode made no difference, we should now try resetting the NVRAM. Since you haven't specified the model of Mac you're using, refer to Apple's How to reset NVRAM or PRAM on your Mac page.

[EDIT] - Known bug in Google Chrome

Not really an answer - at least not the one you're looking for - but I decided to check https://bugs.chromium.org to see if this was a known issue. It appears a number of issues relating to copy and paste (and the clipboard generally) in Chrome for macOS have been raised by users. In some cases the issues affect only text, while in others images and text. Some of the reported issues affect Windows, Linux, etc.

Below are some examples:

It's hard to know whether any of these are related to your issue or not, especially since not everyone can reproduce it, but it could also be an intermittent bug or combination of bugs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .