3

I'm suddenly unable to use the dictionary look up feature in MacOS. When I choose "Look up" on a word I get a dialog saying that "Look Up now shows personalized suggestions... etc" and a button on the bottom that says "Continue" (see image). But the button does not respond to clicking it, so I'm stuck with this message. Neither updating the OS nor restarting seems to mend the issue.

enter image description here

Using MacOS High Sierra 10.13.3

1
  • For anyone who just wants to disable the Look Up, especially in the terminal - System Preferences -> Trackpad -> Uncheck Force Click and haptic feedback. – bdetweiler Aug 27 '19 at 19:07
2

Found a quick fix. Just turning of Spotlight suggestions in Look up brought back the dictionary. enter image description here

Not being able to click the button previously still seems like a bug to me though.

0

Been having similar problems. The dictionary app wouldn't work at all. Updated os, deleted plist file on advice. The app would work but would only give results from Wikipedia. Spent three weeks trying to figure it out. Lots of posts were about proxies blocking certain files causing the dictionaries not to download.

I usually run a VPN but had not turned it on for a while. Turned it on and opened the dictionary app and the dictionaries downloaded. Problem solved! I should point out that I was using my work machine and there had been an update to our security stuff which I suspect was blocking the app from downloading the dictionaries. Also, I tested the app without the VPN and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .