0

I work on an iMac (Late 2015) with macOS High Sierra (10.13.3). On this computer I use a Bluetooth keyboard and mouse.

The computer should wake from sleep if the peripherals are used. The corresponding option "Allow BT devices to wake this computer" is activated.

For the past few weeks, unfortunately, the computer does not wake from sleep if the BT mouse or keyboard are used. Specifically, it does not wake in 80% of the cases. Sometimes it works, but most of the time it does not.

If it does not wake on BT action, I can wake it up using a slight touch on the power button. The computer awakes up, but there is no connection to the keyboard and the mouse. Also, there is no warning message, which usually pops up if the connection to a BT keyboard is lost.

The only thing I can do in this situation is to force restart unsing power button.

There are a lot of similar questions on AD but non of them has an accepted answer. Most commenters suggest to try the common things like restart (muhahaha) reset SMC and PRAM and so one. This did not work for me and it did not work for all the other OPs. In some older questions the problem was solved by updates. Currently there are no updates available.

Does anyone know how to fix this issue?

  • Have you tried updating to macOS 10.13.4? – Allan May 5 '18 at 13:44
1

I noticed that when I connect the charging cable to either the mouse or keyboard and the MAC, that device starts working (because it's functioning as wired instead of BT). So I have my keyboard permanently plugged in to the charging cable and I have a wired mouse to use on standby when the BT mouse fails to wake.

0

Have you tried plugging in a wired mouse? I have the same problem and this works for me. Bluetooth usually starts working shortly after.

-1

I have a usb mouse plugged in all the time because I can't depend on b/t to be alive when I try to bring the mac out of sleep with either the keyboard or apple mouse. This gives me operational control, but I still know my computer isn't working right.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .