2

It's come to the time to upgrade and therefore sell my old laptop. Its a mid-2012 13″ MacBook Pro with an Intel Core i5 and 4GB RAM. Originally it came with a 500GB hard drive but I have upgraded this myself to a Crucial 480GB SSD.

After I used Time Machine to back up my data, it came time to wipe the SSD. I did some research beforehand and was told a secure erase with multiple passes is unnecessary on an SSD, and I therefore followed Apples instructions on how to prepare my laptop for sale:

  1. I logged out of all iCloud services
  2. Restarted and booted into (I think) recovery or internet recovery (command + R)
  3. I went into Disk Utility, selected Erase, selected my Crucial SSD and erased it with the AFPS format
  4. I then reinstalled macOS High Sierra and created a new user.

I wanted to test if the erase had worked, so I went on the internet and downloaded some free data recovery applications (Disk Drill and Easeus). After a few hours, to my horror, all my data came back, in the exact same path and was easily readable and recoverable. I did some more research and was told that encypting the disk would be a good way to securely erase the data (I wish I knew this beforehand!), so I turned on FileVault, let it encrypt the disk and then went through the same stages again of wiping the drive with AFPS format.

Does FileVault encypt data that has already been deleted? I ran the same recovery software for a second time, which again, found all my old files in the same paths, however this time I couldn't preview or open them once recovered. Is this FileVault at work or has something else gone wrong that could easily be fixed by someone wanting to access my files?

What can I do? It's alarming me that the names of all my files are still easily found in the same directories with free software found at the top of a google search, but I don't mind too much if they cant be opened. Is there something else I should be doing to permanently erase this free space? Is my data essentially safe?

  • 1
    When you upgraded your HDD to an SSD, did you enable TRIM? See this post: apple.stackexchange.com/a/258171/119271 – Allan Mar 3 '18 at 16:06
  • Hi allan, no I can't remember doing this to be honest. I read about it but didnt do any terminal commands etc. – Jim Coey Mar 3 '18 at 16:29
  • 1
    TRIM is the ATA command subset for SSDs that mark deleted space as unused and if a read command comes in, it returns either zeros or jibberish. If it wasn't enabled, it "acts" like a regular drive meaning data is recoverable. I suspect this is the case. In the link I provided, it gives you instructions to wipe the drive. Enable TRIM then do a single pass of zeros. Your data will be gone – Allan Mar 3 '18 at 17:15
  • Will my SSD definitely support TRIM, and if I enable it could I fill the SSD with 480gb or so worth of files and then delete them all? would this effectively be the same as writing zeroes? Or should I just follow those instructions and write zeroes? – Jim Coey Mar 3 '18 at 20:28
  • Your SSD will support TRIM. Filling it with 480 GB or filling with zeros is the same thing; just the zeros are easier. It’s like comparing the weight difference between a ton of lead or a ton of feathers. – Allan Mar 3 '18 at 21:35

You must log in to answer this question.

Browse other questions tagged .