1

It's a Mac Mini, Late 2012, 2.4 GHz Intel Core i7, 16 GB RAM and an internal fusion drive of 1 TB, running macOS High Sierra 10.13.3.

The issue is that it's running so slowly that there I can move the mouse and it takes up to sixty seconds (on one memorable occasion, eighteen minutes) for the cursor to move on the screen. I launch an application and it's two or three minutes before it's available. I say available, but it's not really available unless I'm prepared to move the mouse and then go for a coffee whilst it acknowledges the action.

I ran top command:

Load Avg: 58.82, 38.48, 36.87

It's a relatively new installation - about a month old. There are four USB drives hanging off a powered hub, but disconnecting them does nothing to speed up the system. I launch ActivityMonitor and watch it for a while. The CPU usage is about 98.8% idle. Once I start to use the Mac, I see 'kernel process' which can run up to 1600% of CPU. The fan is on constantly and is extremely loud.

The applications that I can see running (in the Dock as opposed to in the background or via a terminal) are Safari, Mail.app, WhatsApp, iTerm2 (with eight tabs), Gedit and of course, Activity Monitor. Quitting them all doesn't eliminate the 'kernal task', although if I don't touch the Mac, that will disappear after about half an hour.

Here is the output of top at the moment, when things are relatively calm:

Processes: 289 total, 2 running, 287 sleeping, 1053 threads                15:17:07
Load Avg: 1.56, 2.67, 4.64  CPU usage: 2.78% user, 2.17% sys, 95.3% idle   SharedLibs: 316M resident, 63M data, 50M linkedit. MemRegions: 36312 total, 2305M resident, 166M private, 565M shared.
PhysMem: 7084M used (1815M wired), 9298M unused. VM: 1277G vsize, 1100M framework vsize, 0(0) swapins, 0(0) swapouts. Networks: packets: 355317/388M in, 229733/35M out.
Disks: 390366/11G read, 226405/11G written.

In the menu bar, I previously had stuff such Adobe CC, JumpCut and Skitch. I have killed those, and restarted after removing them from 'startup'. I've also tried the usual stuff like repairing disk permissions etc.

I don't know what to do at this point, and am tearing my hair out in frustration. All advice gratefully received.

  • 1
    If it's a fusion drive, I am willing to bet that your spinning drive is failing (it's a 2012 after all). See this relevant post: apple.stackexchange.com/questions/229372/…. Also, I would download Disk Drill and run their SMART diagnostics. – Allan Mar 2 '18 at 15:31
  • 1
    Did you check for dust inside? Power down your mini, turn it over and rotate the bottom plate (there are some markers to show the direction) to look inside. – nohillside Mar 2 '18 at 16:56
  • Sounds very much like hardware failure - most probably related to the disk drives. Check out the Console / system logs to see if any disk related errors are missing. Also run a system diagnostics. The load average being so high with the CPU almost 100% idle means that the computer is waiting for I/O - i.e. your disk drives. – jksoegaard Mar 2 '18 at 21:48
  • 1
    Though linked dupe is about a MacBook Pro, the hardware isn't vastly different; the symptoms and solution are the same. Possible duplicate of My Mac is getting really slow, what should I do? – Allan Apr 16 '18 at 14:01
1

In my experience, unusually slow Macs are usually slow due to hard drive failure, or Malware installation (or in the case of MacBook Pros, a bad hard drive cable). Those are the common causes these days.

Step one: Download SMART Utility and see what it says about your physical drives. If your HDD is failing, it will tell you right away. (Note: it can't check the SMART status of most external drives, leave your externals disconnected through this whole process, and until the Mac is running normally again)

Step two: Download and run MalwareBytes for Mac, and run it. The free version is all you need. Remove anything it finds.

If none of these end up being the cause, then you have something much less common going on on your machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .