0

My understanding of standby modes in MacOS is they will not be triggered with an external disk. However even though I explicitly set my power settings not to sleep the disk, it still does.

enter image description here

$ pmset -g
System-wide power settings:
Currently in use:
 standby              0
 Sleep On Power Button 1
 womp                 1
 autorestart          0
 hibernatefile        /var/vm/sleepimage
 powernap             0
 networkoversleep     0
 disksleep            0
 sleep                60
 autopoweroffdelay    14400
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         10
 standbydelay         4200

Why is this happening and how do I stop it?

I should add I've been using this Mac Mini with this drive and it never used to have this issue. It is my OS drive so if it turns off, things go wrong so I would've noticed.

I wonder if it's linked to autopoweroff AKA Deep Sleep but shouldn't the disk come back on at power-up anyway?

1
  • Some drives have their own power management features internally. You could check this. However in my case I found out it was a failing USB port that was causing the issue and put the drive in a new chassis. – unknowndomain Mar 2 '18 at 17:22
1

Some brands ignore your preferences in favour of their own power down schedule. Most notably Seagate.

The only thing you can do is change to another brand of drive that respects your preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .