I have an External 1TB hard drive that has been corrupted, it was so corrupt that I had to abandon the files on it. So now I'm simply trying to erase it so I can begin using it again. But here's the problem; the External HD will show up in Disk Utility but it wont mount the (FAT32) partition. And even when I try to reformat the drive it simply won't do it.

Screenshot of my Disk Utility
Any suggestions would be greatly appreciated, I've been trying to fix this for I don't know how long.

  • Instead of erasing the drive, try erasing the volume. So click on the "UNTITLED" volume, and try erasing that.
    – daviesgeek
    Nov 19, 2011 at 22:31
  • Already tried that, format stalls on the unmounting of the drive.
    – nkcmr
    Nov 19, 2011 at 22:34

1 Answer 1


If you do not care about loosing the data already on it, try changing the partition scheme instead of formatting it.

Select the drive like in your screen shot, then click on Partition tab on the right, then select 1 partition from the pop-up menu on top of the graph. Then click Options at the bottom and select GUID (the first option) in the next window, close it, and then click Apply in the main window. You can also set the format of the partition before you click apply. It should already have selected Mac OS Extended. All this assumes of course that you wish to use this drive with a Mac and only a Mac… if you want to use it on a PC and a Mac, you'll have to select other options, but still possible.

If that still doesn't work, it's probable the drive is physically damaged.

What you have right now is a Windows Partition scheme and a FAT formatted partition. I could be mistaken, but I think FAT32 does not work on OS X. I'm only 50% sure though...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .