7

Recently I have downloaded and installed macOS High Sierra. Downloading went well, installing went well, no problems during that process. Only when my iMac started back up I saw nothing new. It looked like it didn't install anything at all. So when I checked which OS it was running it said 10.9.5 (Mavericks).

I thought it might have been an error and I tried to reinstall the new OS. However, when I wanted to download the installer again in the Mac App Store, it said that it the OS had already been installed.

And so began my search on the internet to find a solution. I came across a post on the Apple Support Forum. It said that I should look in my applications folder to see if I still have the installer. Fortunately this was the case. Only when I ran the installer it told me that it had failed to download the necessary information from the installer. In other words: it could not run the installer.

Maybe something interesting I found online; I came across this reply from deontaifromroseville on the forum. Here's the most important part:

Listen... I have been at this computer all day and night. Starting at 10:30a on 1/16/2018. If you see the downloaded or installed on Sierra in the App Store WITH A GRAY TAB YOU CAN NOT CLICK. It is because you have DOWNLOADED AND INSTALLED.

OPEN APPLICATION. CLICK ON LAUNCH PAD. YOUR INSTALL SCREEN OF SIERRA WILL POP UP AFTER.

However, the solution he found did not work for me. But it's still interesting because I have successfully gone through the entire installation process. Maybe it is installed but there is something else at play?

So, I still have not been able to get the latest macOS. Does anyone know more about this problem? Has anyone else experienced this same issue? Is there a solution? All information is helpful.

  • 1
    If the macOS installer is still in the Application folder, then clearly the new OS is not installed. The installer will be deleted after successful installation. Also in the App Store, it will show INSTALLED even if you have downloaded the installer and did not install the OS. – Pratik Mar 2 '18 at 9:20
9

CLICK ON LAUNCH PAD. Then you should see an application icon to install MacOS High Sierra. Use that to continue your unfinished OS upgrade.

2

That is very strange. This may sound extreme but not sure there is another way.

Use the installer with a program called Diskmaker X and a (minimum) 8GB thumb drive. Once the installer has created the bootable thumb drive, eject it and back up your Mac. If you can make a disk image or clone it to another external drive, all the better.

Once that is done insert the thumb drive and reboot the Mac holding down the Option key. Soon you will get to the boot drive selection screen, select the installer and let it boot. It will take a while longer than you think it should.

When you get to the installer screen where you have a menu bar, find disk utility, launch it and select the partition that you tried to upgrade and format it. Once that is done (should only take a minute or less) exit out of disk utility and proceed with the installation.

You have just done a clean install of macOS. Once that is done, boot your system and create a user with a different username than the one you used on your backup. Log in and apply any updates that the App Store shows as available.

Once that is done run the Migration Utility (/Applications/Utilities) and connect the backup drive and mount the disk image that contains the backup (if that is the way it was done.

You can now use the Migration Assistant to move all your files and applications and settings back to your Mac.

You can then log out of the account you created and log in with the username and password you used previously. You can delete that account or just leave it there for troubleshooting purposes.

Yeah, this is a pain and it will take a couple (or more) hours to do, but should guarantee you get a solid (upgraded) system and your environment (with apps and files) back.

1

If you don't want to look at your installer logs and see what error happened, you might have better luck installing an older OS (Sierra or something half way between 10.9 and 10.13)

If that fails, you may need to make a bootable installer or re-attempt the install and then look over the installer log.

I also have very good success with making a time machine backup and then an erase install.

1

Do you happen to have another bootable drive attached to your system (e.g. a bootable backup)? If so, then it may be that you did install the new OS to your regular drive, but when you reboot your system it can't (for whatever reason) boot from it. In which case, the system will attempt to boot from the next bootable drive it can find. Which would be a drive with your old OS.

If the installer can't create a recovery partition on that drive (e.g. not enough space), then it will fail. Which might explain why the installer is failing on your second attempt to install the new OS.

0

If you open terminal app (/Application/Utilities) you can type:

sw_vers

That gives a quick check of the build and version. Additionally, What does system_profiler SPSoftwareDataType say? That should show the version your system is currently running from, in case the about screen got screwed up.

0

Look in the Applications folder for the Install macOS Sierra app and then double click to install. (Run a Time Machine backup first.) Perhaps the installer has only been downloaded, but macOS Sierra not actually installed

  • Have already used the installer. The newest OS should be installed. However, it loads up the old OS. – Developer May 5 '18 at 12:00
0

This happened to me because I was trying to install the new OS while encrypting the drive for FileVault was in progress. Afterwards, spotlight search allowed me to fine the "Install High Sierra" app and re-run it, which was not possible from Mac App Store due to the button being greyed out.

0

It could be that it is already installed on an external storage device attached via USB. Disconnect and reopen from App Store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .