I use the program No Machine to open up remote desktops to my development servers. I choose No Machine because the client software reportedly runs on Windows/Linux/Mac, but I am having trouble with the Mac client.

When I startup the No Machine (also called NX) client, I get an error message saying "NX Client for MacOS/X was not able to find the Apple X11 Server. Please be sure that the Apple X11 bundle is installed in either the /Applications or the /Applications/Utilities directory and retry."

I have heard X11 is installed by default on Snow Leopard (I run Snow Leopard). I have the X11 app, when I open a terminal and type startx the X11 server appears to start up, but I get a message about a missing .serverauth file.

Any advice on how to get this working?

1 Answer 1


I installed the XQuartz application. It was in /Application/Utilities/XQuartz.app. I just renamed it from XQuartz.app to X11.app and everything works fine, so far.

Update: don't install XQuartz for use with No Machine. I opened a text editor and started typing, all the keys were screwy. For instance, the Delete key was now comma, all the letters were transposed, general chaos. I replaced XQuartz with the official X11User.dmg package and this keyboard problem went away. One more step I had to take: when on the remote desktop I tried to cd into a different directory, and hitting the "d" key kept showing me the desktop. If you want to cd, you will need to go into System->Preferences->Keyboard shortcuts. Scroll down, and notice an entry "Hide all windows and show desktop" which is mapped to "D". Change this to Alt+D or Ctrl+D and cd away!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .