2

I attempted to upgrade from macOS Sierra to High Sierra on my late 2010 MacBook Pro and it failed part way through the installation. On restarting it flashes a folder with a question mark on a white screen.

I boot into recovery with Command + r, go to Disk Utility, perform First Aid and both the internal hard disk and the disk image titled "OS Base System" checks out fine with no issues. I tried unmounting and mounting the hard disk. It still doesn't show any option to choose the disk as the startup disk.

I tried reinstalling macOS from the utility menu and after a long pause it brings up Terms and Conditions. After accepting them, it says it has begun and shows 8 minutes remaining. After staying at 8 minutes remaining for a few minutes it goes to 14h 22m and stays there and has been so for a few hours.

No errors are popping up, and while I don't know much about this stuff, it appears from the installer log it's having some troubles, various errors finding/creating information. I've restarted several times in between all of this stuff and nothing has worked.

I don't believe I have a backup less than two years old and none are showing up as options. How do I resolve this issue?

1

I have faced the same issue with the same MacBook. What worked for me was to restart and immediately press Option key. The computer asked me which start up disk to select. Avoid the updater and select your hard disk. Right now I am trying to figure out how to fix the High Sierra damaged installer. If anyone knows, let us know.

-1

try installing os update no. 4 worked for me seemed to install some missing parts of the HS os

  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info such as what you mean by os update no. 4 and how one can access that specific update? Also, you may want to read How to Answer for tips on providing answers here. – Monomeeth Nov 29 '18 at 21:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.