5

I'm having an issue with my iMac where it hangs during shutdown. It gets to a black screen with just the cursor showing. I am able to login from another computer via SSH and see that it's doing nothing (according to CPU usage). The system.log didn't show anything of interest either. I discovered this when trying to update the supplemental update just released. It won't install because I have to do a hard shutdown (either holding the power button or issuing sudo shutdown -r now via ssh).

I read that booting into safe mode can get you past this but every time I try it hangs before completing boot-up. I've tried disabling all startup items and launch items but hasn't helped. I've tried resetting SMC and PRAM and Disk First Aid. Single user mode still hangs on shutdown.

Obviously I could try reinstalling but I want to avoid that if possible. Any other suggestions?

  • I would try reinstalling, then applying the update. If that doesn’t work then you might need to erase the disk and reinstall from scratch. – At0mic Feb 27 '18 at 18:43
4

I had the same issue. In my case I was able to see in log that there was problem with cache files permissions. I removed them and now I'm able to install update and restart MacBook without issue.

sudo rm -rf /var/folders/zz/zy*
sudo shutdown -r now

NOTE: some of cache files ware skipped due to system integrity protection - Operation not permitted

  • 1
    Genius! That worked. Didn’t matter about the skipped files like you said. Was able to install the supplemental update at last – Mark Robinson Mar 13 '18 at 16:14
  • Such a random thing to try, but solved the issue for me as well. In my case after trying to install Security Update Developer Beta 2018-003, and the system refusing to restart normally. I was continually getting a black screen with a cursor on restart from GUI. (sudo shutdown -r now worked). This solved it. – Gajah Duduk Nov 9 '18 at 18:35
0

I had almost the same problem (except the hang up during boot, it just took longer to boot) and found another solution. In my case, kernel files from "XBox 360 Wireless Controller" were responsible. Deleting them solved it, but of course I can't use my XBox controller anymore with the iMac...

Location of files

in /Library/Extensions:

  • 360Controller.kext
  • Wireless360Controller.kext
  • WirelessGamingReceiver.kext

in /Library/LaunchDaemons:

  • com.mice.360Daemon.plist

in /System/Library/Extensions:

  • 360Controller.kext (no file, just symlink)

You must log in to answer this question.

protected by Community Aug 8 '18 at 17:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .