5

I am using Dell P2715Q display (4K) with MacBook Pro (Retina, 13-inch, Early 2015). It is by default scaled to 1920 x 1080 @ 60 Hz (copied from System Report). But the display shows "Resolution: 3840x2160, 60Hz" (at the bottom of the Menu). It bothers me cause I have some performance issues working with this display. I also have Dell U2715H display (2K) at home which doesn't show any performance problem at all. I assume the problem is in Mac OS scaling but don't see a way do diagnose or fix it.

Mac OS Sierra Version: 10.12.6 (16G1212)

  • 1
    It sounds like this may have to do with the settings on the monitor. Is there a menu you can pull up using buttons on the monitor? If so, have you checked to make sure the resolution is not locked? You could also try automatic configuration if your monitor supports it. – Jake3231 Feb 26 '18 at 13:52
  • Yes, "Resolution: 3840x2160, 60Hz" is displayed in this menu. I do not see any resolution setting there. – Dmitriy Dokshin Feb 26 '18 at 13:54
  • Thank you. Does your monitor support automatic configuration? – Jake3231 Feb 26 '18 at 13:56
  • I think this is what happens. – Dmitriy Dokshin Feb 26 '18 at 13:58
  • As I understand resolution value is always set by source. I can assume it based on my experience with Samsung UE49KS7000 which shows right values of resolution when they are changing. – Dmitriy Dokshin Feb 26 '18 at 14:01
5
+50

What you're describing is macOS' "Retina" HiDPI scaling feature. The actual resolution that the GPU renders, the display sees and what is communicated over the display-cable is 3840x2160.

In simple terms, the resolution reported to applications is instead 1920x1080. This means that the actual usable resolution you'll find as a user is 1920x1080, but for example text is rendered "crisper" by macOS taking advantage of the underlying full resolution. Similarly images and video material can be shown in the underlying full resolution.

If you open System Preferences and select Display, then you see the scaling option you have chosen for your monitor. You can hold down the option/alt key while pressing the "Scaled" radio button to reveal a longer list of possible screen resolutions. You want to select one marked "low resolution" (i.e. not a HiDPI one).

You can also use third party utilities such as SwitchResX to get even more options for screen resolutions.

You can also disable HiDPI scaling completely from Terminal.app by running the following command:

sudo defaults write /Library/Preferences/com.apple.windowserver DisplayResolutionEnabled -bool NO

You'll need to reboot afterwards.

To reverse and enable HiDPI again, change "NO" to "YES".

  • 1
    Great answer, thank you! I guessed the same. But it still doesn't explain why for Samsung 4K TV (check my comment for the question) MacBook renders right resolution, the one that I expect. – Dmitriy Dokshin Mar 2 '18 at 14:27
  • Special thanks for the command. But it looks like it does not work actually. The value is set correctly (now it is 0), but the resolution displayed in the monitor menu is 4K and I can not see any difference in the picture. – Dmitriy Dokshin Mar 2 '18 at 14:31
  • @DmitriyDokshin TV reports itself as such, Dell or most other monitors report themselves as such. Check System Information. MacOS must only use Retina on monitors? – Matt Sephton Mar 2 '18 at 20:48
  • No, I'm using "Retina" also on 4k TVs - so it is not monitor only. – jksoegaard Mar 2 '18 at 21:44
  • I'll check again my TV later. Maybe I made a mistake somewhere. – Dmitriy Dokshin Mar 2 '18 at 21:55

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.