1

My early 2008 MacBook runs on a dual boot of Snow Leopard OS X 10.6.8 and Ubuntu 16.04. I deleted some partitions, so I am unable to boot either OS X or on Ubuntu. I tried a repair by using installation DVD Disk Utility and Time Machine, but both are unable to find the target volume.

  • Have you booted from the recovery partition and tried the reformat the hard drive first? – Maximus Feb 26 '18 at 14:34
  • I booted from the disk utility install disk. In snow leopard there is no recovery partition. The problem is the hard drive is not visible any more, I think I need something like refinder , a booting app, but probably I deleted this partition on my hard drive. – Aldo M. Feb 26 '18 at 14:58
  • 1
    Boot from the installation DVD. Open a Terminal application window and enter the command gpt -r show /dev/disk0. Post the results to your question. Also, do you have a Time Machine backup of the OS X partition? – David Anderson Feb 26 '18 at 15:22
  • Thank you for your help. The command you gave me resulted in:" gpt show: unable to open device dev/, no such file or directory. gpt show; disk0: suspicious MBR at sector 0" – Aldo M. Feb 27 '18 at 8:22
  • After many trials and errors I managed to boot from the installation disk. So I could restore my old 10.6. 8. system. – Aldo M. Mar 2 '18 at 6:42

You must log in to answer this question.

Browse other questions tagged .