I have the MBP 15" model 2017 (macOS High Sierra 10.13.3) with touch bar. What I realized is that the touch bar volume element (mute / unmute / volume up / down) does not work. I press them but nothing happens.

On my apple external keyboard these shortcuts work fine. Also when I try to adjust the volume with the touch bar slider it works like it should.

I tried different things, resetting nvram, removing / adding the controls, killing the control strip, killing the coreaudiod, resetted SMC. but nothing seems to fix it. The only thing that worked is opening a new user account. In the new user account everything seems to be working fine.

Any ideas of what the problem might be or how it can be fixed?

  • I may have similar issue. Does this happen all the time or seemingly random? Commented May 24, 2018 at 0:32
  • Hello @Josh. It happened all the time. Commented May 25, 2018 at 11:06

7 Answers 7


Seems to be a bug that shows if you plug an external display, etc.

Open Terminal.app and type:

killall ControlStrip
  • My control strip is broken so this would not work, Stephen Huff answer works in those cases. That being said killall ControlStrip works in most cases where the ControlStrip is not totally busted.
    – Subtubes
    Commented Nov 14, 2019 at 0:20
  • you are awesome. Commented Aug 26, 2023 at 16:17

The problem is the MAC thinks the external monitors have a speaker when they don't.

Goto System Preferences -> Sound -> Check "Show Volume in the menu bar".

Then from the Volume Bar in the menu bar change the "Output" back to "MacBook Pro Speakers"


For anyone who might have the same problem, it seems to be a weird bug on High Sierra at least.

When the "slow keys" are enabled (system preferences -> accesibility -> keyboard) the volume controls (maybe other control keys too?) on the touchbar do not work.


I have the same issue as the the OP, and haven't found a fix But thank you Cobra Kai Dojo for identifying the link between slow keys and the malfunctioning volume control! At least now I have control back :) Haven't noticed other TouchBar keys not working with slow keys turned on though.

However, I did notice that typing in general got a lot less predictable with slow keys turned on (randomly dropped characters), and esp Apple & Option keys were just not working on first try (for keyboard shortcuts). I've turned off slow keys, and now it's back to behaving - for now.


What fixed it for me was to uncheck Enable Touch Bar Zoom in System --> Accessibility --> Zoom. I had inadvertently checked it when I was making some other changes.


Not to be rude but did you google this?

Did you by any chance reset SMC? https://discussions.apple.com/thread/7785100

When did it start happening?

Software update?


Restore from backup?

Do you have 2017 or 2016, 13" or 15"

You could just move all your data to a new user account.

  • 1
    I have updated my question. Yes I've tried resetting the SMC without any luck. I am with the latest software update. Tbh I haven't done anything special that could cause this problem... or at least nothing comes up in my mind... Commented Feb 26, 2018 at 14:59

This is kind of a nuisance to have to get used to but kinda cool - and since I had the same issue and realized it's not a glitch here’s what I learned.

With the new update I recently applied, the volume on the Touch Bar is now a press/ hold and slide.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .