3

I was trying to access the Recovery Mode on my MacBook Pro5,3 with OSX El Capitan 10.11.6, however every attempt ended in Kernel Panic (KP). I would see the Apple logo with a loading bar and the following console-like text as an overlay:

panic(cpu 0 caller 0xffffff8013b9654e): "Process 1 exec of /sbin/launchd failed, errno 5"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3248.60.10/bsd/kern/kern_exec.c:4584
Backtrace (CPU 0), Frame : Return Address
0xffffff8117153de0 : 0xffffff80136dab52 
0xffffff8117153e60 : 0xffffff8013b9654e 
0xffffff8117153ee0 : 0xffffff8013b6df9b 
0xffffff8117153f00 : 0xffffff8013bb3dd1 
0xffffff8117153f40 : 0xffffff80136d54cd 
0xffffff8117153f80 : 0xffffff80137cef3e 
0xffffff8117153fa0 : 0xffffff80137ec52f 

BSD process name corresponding to current thread: init
Boot args: rp=file:///com.apple.recovery.boot/BaseSystem.dmg

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 15.6.0: Thu Jun 23 18:25:34 PDT 2016; root:xnu-3248.60.10~1/RELEASE_X86_64
Kernel UUID: B5AA8E3E-65B6-3D0E-867B-8DCCF81E536C
Kernel slide:     0x0000000013400000
Kernel text base: 0xffffff8013600000
__HIB  text base: 0xffffff8013500000
System model name: MacBookPro5,3 (Mac-F22587C8)

System uptime in nanoseconds: 1874205854

What I have tried

  • Rebooting with CMD+R - results in KP
  • Rebooting with Option+CMD+R - results in KP
  • Rebooting with Shift+Option+CMD+R - results in KP
  • Rebooting with Option and then selection the Recovery partition - results in KP
  • I found that the BaseSystem.dmg on the Recovery HD partition was corrupted, so I replaced it (together with the BaseSystem.chunklist file) with a fresh version from the El Capitan installer. To no avail, I got a KP again, albeit a slightly different one:
    panic(cpu 0 caller 0xffffff8003c3995e): "A kext releasing a(n) BroadcomBluetoothHostControllerUSBTransport has corrupted the registry."@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3248.60.10/libkern/c++/OSObject.cpp:200

What else can I try?

My final goal is to boot to Recovery, disable csrutil, patch a system file such that my headphones don't launch iTunes automatically, then enable csrutil again.

Notes

Booting to Safe Mode by holding Shift during startup does work as expected.

3 Answers 3

3

Unfortunately I wasn't able to get Recovery Partition Creator working despite many attempts.

But I found an alternate approach which I actually liked better because you can see inside the script that's used to create the recovery partition to see what it's doing (unlike Recovery Partition Creator):

  1. Download the Lion Recovery Update from https://support.apple.com/kb/dl1464 and make sure it's in your Downloads directory

    (Don't worry that it's for OS X Lion; it's not going to install a Lion recovery partition, it will only use a utility inside that package to create a recovery partition with the version of macOS you choose in the next step)

  2. Get the InstallESD.dmg file

    1. Download macOS: https://support.apple.com/HT211683

      Pick whichever version you wish the recovery partition to be (probably whatever version of macOS you're using)

    2. Double-click the .dmg file to open it

    3. Drag the .pkg file inside the .dmg file somewhere to extract it

    4. Extract the contents of the .pkg file

      cd /path/to/InstallMacOSX.pkg
      pkgutil --expand InstallMacOSX.pkg InstallMacOSX
      
    5. Go to the new InstallMacOSX directory where the .pkg file was extracted

    6. Right-click the InstallMacOSX.pkg inside the InstallMacOSX directory > Show Package Contents

    7. Copy InstallESD.img to your Downloads directory

  3. Download http://4unitmaths.com/recovery.sh.zip and extract it

  4. Run recovery.sh

    cd /path/to/recovery.sh
    chmod +x recovery.sh
    sudo ./recovery.sh
    

Source: https://forums.macrumors.com/threads/how-to-recreate-recovery-partition.2261166/post-29049322

0

After I forgot this issue for a while I stumbled upon a very useful tool made by Chris Silvertooth. The latest version of his Recovery Partition Creator can be found on his download page (note: the webarchive lacks a copy of the script itself, but here it is on mediafire).

Using the application is very simple, I have successfully recreated my recovery partition on El Capitan (OS X 10.11.6):

  1. (Optional but recommended) Create a full backup of your system
  2. Download the most recent Recovery Partition Creator
  3. Download the relevant OS X installation files from the App Store
    • Open the App Store
    • Open the Purchased tab
    • Find the installation file of the OS you're trying to add a recovery partition to and download it
  4. Start the Recovery Partition Creator and follow the steps described in the dialogs. At some point you will need to point it to the installation files downloaded in the previous step.
5
  • Hello Saaru, have you managed to fix the kernel panic ? This solution does not work as I am stuck in a kernel panic, especially after all the attempts you mentioned. Commented Apr 19, 2020 at 12:15
  • I have a different laptop now. But what does stuck in kernel panic mean? For me the issue only occurred when I tried to boot the recovery mode. Is that the case for you as well? Commented Apr 19, 2020 at 12:33
  • No my case is different. I always get panic cpu 2 caller 0xff dessert failed buildroot/library/caches/come.apple.xbs at startup over and over again. I literally tried all startup modes (internet recovery, hardware diagnostics, stand alone, vault mode) but i'm stuck in the loop. Any advice ? Thanks so much. Commented Apr 19, 2020 at 12:41
  • I even tried booting on startup. The bootable USB doesn't even show !! I ran hardware diagnostics and I was informed of no issues. Commented Apr 19, 2020 at 12:42
  • Different kernel panics are not comparable to each other, so if your situation is not the same as mine was, it's better to ask a new question. In that case please read the guide on asking a good question. Commented Apr 19, 2020 at 12:47
0

It took me a while to find an answer for this in 2024. I’m using a 2009 Mac mini with Mac osx 10.11 El Capitan.

After a few failed attempts I was able to get it working.

Make Sure To Delete The Old Recovery Partition

In terminal just run the diskutil commands

  1. diskutil list

  2. diskutil eraseVolume JHFS+ Blank [RECOVERY IDENTIFIER]

Then just merge with your main disk using disk utility

Afterwards just follow the steps outlined above

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .