1

I have an external 2-TB hard drive I backup my computer to whenever I can remember. The last time I did this was December 2017; back then, I had macOS Sierra. I now have macOS High Sierra and am attempting my first backup since the update.

When I attempt this, it says "preparing backup" and then starts the backup, but it interrupts itself and doesn't give me any warning.

I've tried running first aid with Disk Utility on the external drive, but Disk Utility said that the drive appears to be fine. I've also tried deleting all of my old backups, but the problem persists.

I've tried this a few times, always with the same result. The last time, the Time Machine preference pane started showing a little red "i" button next to where it says "Latest backup: None"; if I press it, I get the following message:

Time Machine couldn’t complete the backup to “SeaGate”.

An error occurred while copying files. The problem may be temporary. If the problem persists, use Disk Utility to repair your backup disk.

My external drive is fine. Disk Utility can't find any problems with it, I've made many backups to it in the past, and I can read all of the non-backup files I have on that drive (I don't just use it for backups). The problem has to be something related to High Sierra.

What can I do to fix this problem? I'd rather not reinstall High Sierra or do anything too drastic or time-consuming like that if there's another solution.

Thanks in advance.

You must log in to answer this question.

Browse other questions tagged .