28

I've tried logging out and back into my Apple ID account on my Mac, but some (not all) messages are showing the red exclamation point and "Not Delivered", but when I go to the same thread on my phone the message shows up as delivered. I've also checked some of them with one of the people I was chatting with and they are being delivered.

This behavior started 2 or 3 weeks ago.

one message with "! Not Delivered" and another with "Delivered"

10
  • 1
    I do not have the same problem, but Messages.app on HighSierra is at least a little buggy. Sometimes I will send a text message through my Mac and it will go to the bottom, but when the other person replies it will go above my sent message. It will happen many times in a row, causing all my text messages to appear below the other person's. That's with text messages anyways.
    – cmarangu
    Feb 21 '18 at 17:48
  • after about a month (total) this stopped happening. I didn't do anything to solve it.
    – dwightk
    Mar 20 '18 at 16:47
  • lol. did you update your macOS?
    – cmarangu
    Mar 20 '18 at 18:56
  • nope... nothing changed except the Not Delivered messages went away (well, they stopped appearing for new messages... the old ones are still there)
    – dwightk
    Mar 20 '18 at 19:01
  • As for me the text messages are still in their glitched out order. I haven't texted from Messages.app recently, though.
    – cmarangu
    Mar 20 '18 at 19:08
23

What are the chances? I just helped someone with this an hour ago. This worked for her.

It appears that the messages database is corrupted. The only fix is to remove all messages.

From here with edits

  • Quit out of Messages for Mac

  • Go to Finder

  • Hit Command+Shift+G to bring up the “Go To Folder” window

  • Enter ~/Library/

  • Move the Messages folder to Trash

  • Restart the Computer

  • Open Messages (Nothing should be there) and Test

If it works, great! Otherwise comment back here.

Note: This will delete all messages from your Mac

12
  • @TylerNZ If this helped you please upvote it by pressing the upward arrow to the left of the answer.
    – JBis
    Aug 1 '18 at 19:49
  • This is working so far on 10.13.6
    – Tom
    Aug 20 '18 at 13:54
  • I read "Restart" as restart the messages application. It definitely means restart the computer! Sep 24 '18 at 15:50
  • 1
    @BillShirley Fixed.
    – JBis
    Sep 24 '18 at 16:13
  • This happens constantly to me ... never knew how to fix it! Thanks :)
    – drfence
    Dec 12 '18 at 15:51
7

In my case I needed to Settings->Messages->Text Message Forwarding on the iPhone and deselect old devices there, plus select and confirm new one (the one I had trouble with).

1
  • This worked for me. I set up a new mac desktop and couldn't send iMessage to non-iPhone users. It was saying Not Delivered. Then I went to my iPhone and selected the new desktop under "Text Message Forwarding". Then I was able to send SMS to non-iPhone users from Desktop
    – pcantalupo
    Feb 13 '20 at 14:31
4

This solution worked for me by Ralph Johns from Messages says "Not delivered" on Apple Support Communities. It seems to be the same problem as described here.

AS a test deselect the iPhone Number as a Receive Item (it will close the Drop Down for Start Conversation From) so that the Mac can only Send (And Receive) from the Apple ID

Now start a New Message.
in the "to" spot type in your iPhone Number in full including the country code.
(The My Details are not called up if you try your name as you are not expected to call yourself).

Before send go to the iPhone > Settings > Messages > Send and Receive and deselect the Apple ID (don't log it out just deselect it).
This bit will stop any Sync copy showing up from the Send of the Apple ID on the Mac.

Now send an iMessages from the Mac.

Does the iPhone Receive it ?
If not then the Apple ID is not logging in properly on the Mac.
As a first Step try Logging out (Sign Out button) on the Mac version. Quit the app before relaunching the app and signing back in again.

Repeat the test above. If it still does not work then use this Users Tip When the iMessages account will not Login
There is no way to speed up the last section where you have to contact Apple Support and get yourself moved up the chain of Responders until one can look at the Server and tell if your Apple ID when used from the Mac for iMessages is blocked. (your serial number is used for a device specific login so only one device can be block meaning the ID works in other places and devices).
You then still have to wait for the Engineers to reset your ID.

1
  • Another USELESS downvote without a helpful explanation on an answer that apparently actually worked.
    – WGroleau
    Aug 29 '18 at 13:22
2

After loooooong time, I rebooted my mac and now looks like the "Not Delivered" messages issue is gone.

2
  • Same happened to me recently. Just magically fixed itself after some period of time.
    – drfence
    Mar 20 '19 at 17:58
  • And this continues ... it comes and goes.
    – drfence
    May 24 '19 at 19:59
1

Deleting the Messages folder in ~/Library is a bit heavy handed. Since I don't have this issue in all of my conversations, I decided to simply try deleting the problematic Conversation. It appears to be working fine now.

Update: The dreaded "Not Delivered" has returned. Trying deleting the Messages folder this time.

1

The solution from Reid Knapp got so many downvotes because of the very convoluted way the original cited author Ralph Johns - a veteran contributor to Apple Support Communities - usually wraps his suggestions in. I'd like to help by squeezing the juice of the Red Knapp's version re-cited from Ralph Johns based on my own experimentation trying to grasp Ralph Johns's thought process. I run macOS Mojave and iOS 12.4.1. You need to follow these steps:

  1. On your iPhone go to Settings-Messages-Send and Receive.
  2. Scroll down to the section "Start conversations From". If your phone number is checked, and if you have other types of incoming and outcoming messages (usually, it's e-mail addresses) listed under this section uncheck the phone number and check any of those e-mail addresses. This is a temporary measure.
  3. Launch Messages on your Mac. Launch iOS Messages and try to send a message to yourself as a test. The message should appear in the macOS Messages conversation list without any hiccups and warnings.
  4. In macOS Messages send a message to either yourself or another contact which is or isn't an iPhone user to test both iMessage and SMS delivery. If the message appears in iOS Messages on the fly and without a loading bar stuck then both devices are perfectly in sync.
  5. Go back to the "Start conversations From" section of Settings-Messages-Send and Receive and put the checkmark back on your phone number.
0

JBis answer above worked for me, but neither exactly, nor the first time...on my desktop I found signing out from Messages entirely, and then deleting both the Messages folder, and the preferences (com.apple.Messages.plist) from preferences folder, then restart and sign in again, worked straight away...however, on my laptop, not so, I had to do it about 3 or 4 times before it finally worked, and this also involved toggling "Settings->Messages->Text Message Forwarding" on and off on my phone, before and after the log out delete thing, and some "Start conversations From" toggling...I have no idea what sequence finally did it, but my point is don't give up, throw all these at it in various permutations and it eventually will work...madness, I know...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .