1

I set up a new Apple Watch yesterday by restoring from the backup of a previous watch. The watch from which the backup came was successfully logged in to my iCloud account. But with this watch, each time I have attempted to log in, I am getting an error:

enter image description here

The error is "Could Not Sign In - There was a problem connecting to the server"

The iPhone I'm doing this on is connected to the internet and logged in to iCloud. I am able to authenticate to iCloud in other apps (verifying App Store purchases, for example). It seems to be just this one task that can't connect.

This has persisted through restarts of both the phone and the watch. Is there a fix? How should I go about troubleshooting?

Apple Watch series 3, watchOS 4.2; iPhone 8, iOS 11.2.5.

  • Have you tried updating to the latest iOS/watchOS version? It just came out yesterday. Maybe that might help? – fsb Feb 20 '18 at 18:29
  • @fsb good idea, trying that now! – hairboat Feb 20 '18 at 18:44
  • While I can't say with certainty that updating watchOS solved the problem, I can say that the problem does not persist after the update. – hairboat Feb 20 '18 at 20:48
  • That's good news! I can add it as an answer and then you can decide if you want to accept it or not. – fsb Feb 20 '18 at 21:05
1

Try updating to the latest iOS/watchOS version.

A new update (11.2.6/4.2.3) just came out and it might fix whatever is causing your issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .