I have a similar problem as the asker in this question on Apple's forum.

After I updated from Sierra to High Sierra (v10.13.3) on a MBP retina 13" mid 2014, I noticed the character picker (special character pop-up) that appear when long pressing / holding a character, e.g. to type ë or ñ, does not appear anymore. However, when such a key is held, the character is repeatedly entered. This is not what I want, because I'm used to the character picker. I don't want to use key with u for ¨, i for ^, e for ´ etc., which I fail to remember and is slower than simply holding to reveal any character variations. That is much more efficient in my opinions and therefore it is better UX.

I've tried the linked question's terminal command without success: defaults write -g ApplePressAndHoldEnabled -bool true

Also, there's a comment in the discussion suggesting rebooting in safe mode and changing some keyboard settings might do the trick. I cannot boot into safe mode, possibly (?) due to administrative restrictions (company laptop).

So, how do I do it? Is the character picker a feature at all, or am I actually experiencing a bug?

  • Same here. Seems like no one knows how to really fix this.
    – dado_eyad
    Commented Mar 1, 2018 at 9:07

3 Answers 3


The problem has 'fixed itself'.

Today, I found out the character picker works again. I have no clue why it did not want to work. Possibly, it requires multiple reboots before the functionality is back (I already rebooted a few times in the meantime). Maybe it's because I fiddled with some keyboard settings. I've also used an external keyboard in the meantime, which could (in some strange way) influence the keyboard settings.

I will never know what has definitely solved the problem.

So, if you're having this problem too, then try setting your keyboard layout to that of your locale, but in the layout of your choosing (mine is Dutch language with US international layout). Then reboot multiple times, or maybe turn off your computer completely a few times. If that doesn't work, connect an external keyboard and try if that works.

If you happen to find a solution or even a cause, report back here in an answer or comment, as it will help others facing the same issue.


Just restarted my Mac in Safe Mode and all the accents have come back


I have noticed that locking my Mac (Control-Command-Q) and login again solve the problem. But it doesn't prevent the problem from coming back after a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .