7

I am running Ubuntu 16.04 via Virtual Box on my MacBook Pro 2017 w/ TouchBar (3.3Ghz i7, 16 GB 2133 MHZ) and I am getting a very laggy and unpleasant experience on the machine. I have gone through the suggested changes from 7 years ago here: https://superuser.com/questions/172989/virtualbox-running-ubuntu-is-slow-mac-os-x-host

But it does not seem to make a difference. Even when I change the resolution to 720p the performance is still quite poor. Here are the settings for the vm:

 <Hardware>
  <CPU>
    <PAE enabled="true"/>
    <LongMode enabled="true"/>
    <X2APIC enabled="true"/>
    <HardwareVirtExLargePages enabled="true"/>
  </CPU>
  <Memory RAMSize="8192"/>
  <HID Pointing="USBTablet"/>
  <Chipset type="ICH9"/>
  <Display VRAMSize="128"/>
  <VideoCapture fps="25" options="ac_enabled=false"/>
  <RemoteDisplay>
    <VRDEProperties>
      <Property name="TCP/Ports" value="3389"/>
    </VRDEProperties>
  </RemoteDisplay>
  <BIOS>
    <IOAPIC enabled="true"/>
  </BIOS>
  <USB>
    <Controllers>
      <Controller name="OHCI" type="OHCI"/>
    </Controllers>
  </USB>
  <StorageController name="IDE" type="PIIX4" PortCount="2" useHostIOCache="true" Bootable="true">

Any thoughts on the settings? I feel like I should be able to get some decent performance out of this machine. (I have tried smaller RAMsizes with no success either). Alternative solutions if this a common Virtual Box issue?

9
1

The problem is Retina itself. If you use other monitor with other resolution (no retina) you'll see much better performance. I think it's an issue with OSX and Retina/HiDPI Resolutions.

1

Using the second monitor for VM definitely will improve performance.

Another workaround could be using a remote connection to VM.

I installed XRDP on Ubuntu VM on my MBP and using RDP client for access, no issues with performance.

Please check this link. There is another suggestion to use tool for Mac to use an additional range of screen resolution, so your VM instance can run smoothly on retina display

1

I know that this question is very old post, but just in case anyone still wondering how to fix/solve this issue...

The problem is on Mac's Retina display, as @Rubén Gómez García stated.

The fix(ish) for this problem is:

Firstly, make scale factor to 100%. This is MUST.

Then, in the Finder, go to Applications -> VirtualBox.app and choose Show Package Contents from the Finder context menu to see the contents of the app package. Continue to go to Contents -> Resources -> VirtualBoxVM.app.

Once you found VirtualBoxVm.app, then open context menu to get to the properties of VirtualBoxVM.app.

Then, under General, there is a checkbox called "Open in Low Resolution", you can disable HiDPI display by checking this. Don't worry, you won't notice the difference between HiDPI vs. Low Res. At least I didn't.

In my environment (Macbook Pro 13inch 2020 with 32GB RAM, Core i7 + Big sur 11.5.2), the performance was greatly improved by doing this setting, so I will leave it here as a reminder.

Feel free to correct/improve my answer.

2
  • 1
    Thanks! This worked for me as well with Big Sur + Vbox 6.1.26
    – joonasj
    Aug 17 at 5:11
  • @joonasj Hey, thanks for feedback! I wasn't sure if it would works for everyone, but I was relieved to hear that it's working fine.
    – Skye-AT
    Aug 17 at 8:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .