4

I have an external hard drive that is partitioned as a single encrypted HFS+ volume.

Here's what's going on: The volume won't mount, Disk Utility won't repair it.

diskutil cs list says:

Diskutil CS List says:

However:

diskutil coreStorage unlockVolume 042F9672-CEEC-47D3-8749-4D4F5A52B6CE -stdinpassphrase

returns

042F9672-CEEC-47D3-8749-4D4F5A52B6CE is already unlocked and is attached as disk5

and

diskutil mount disk5

returns

disk5 is a CoreStorage Logical Volume which failed to mount

Other things i tried:

diskutil cs decryptVolume 042F9672-CEEC-47D3-8749-4D4F5A52B6CE

Which returned

The Core Storage Logical Volume UUID is 042F9672-CEEC-47D3-8749-4D4F5A52B6CE
Started CoreStorage operation on disk5 Cairo
Scheduling decryption of Core Storage Logical Volume
Core Storage LV UUID: 042F9672-CEEC-47D3-8749-4D4F5A52B6CE
Finished CoreStorage operation on disk5 Cairo

But now my diskutil cs list looks like this and it has for an hour.

But now my diskutil cs list looks like this

I'm lost, i'm stuck, i'd need help.

  • thanks, four hours later i'm actually at 2%. mount didn't work but i can't replicate the error message for you here. – Julian Finn Feb 19 '18 at 21:12
  • ah, just listing, not mounting. yeah disk doesn't show there. – Julian Finn Feb 19 '18 at 23:05
  • after conversion going up to about 6% diskutil cs list now tells me Conversion Progress: Paused – Julian Finn Feb 19 '18 at 23:06
  • yeah thanks, somehow it worked again. it's excruciatingly slow (gained 2 percent overnight) but it seems to work – Julian Finn Feb 20 '18 at 14:24
  • You may have to disable sleep/turn off "Put hard disk to sleep when possible"/disable separate sleep functions provided by third-party tools (I think some e.g. Western Digital tools/drivers for WD drives enable it) – klanomath Feb 20 '18 at 15:03

You must log in to answer this question.

Browse other questions tagged .