1

I am heavily struggling with a corrupted USB. The problem I am facing is that I can neither partition nor erase the Disk. The disk is empty and there is not partition created. I can also not find a volume. It is also impossible to initialised the disk or perform any action on disk utility.

Any help is highly appreciated.

$ diskutil list
...
/dev/disk2 (external, physical):
  #:          TYPE NAME             SIZE       IDENTIFIER
  0:                               *16.0 GB    disk2

enter image description here

enter image description here

  • diskutil partitionDisk disk2 1 MBR FAT32 USBFAT R – David Anderson Feb 18 '18 at 17:22
1

Did you try erasing your disk with diskutil? You can do that via this command (assuming your disk is still disk2):

diskutil eraseDisk FAT32 NAME MBR disk2

Here is an explanation of the command:

diskutil: This is a disk management tool provided by Apple.

eraseDisk: Tells diskutil to erase a disk

FAT32: The filesystem format you want to use. You can replace it with any other filesystem, such as JHFS+ or FAT16

NAME: The name of the newly erased disk's new partition

MBR: Partitioning table to use. You can replace it with GPT if you want.

disk2: Your disk's identifier. Replace it if your disk's identifier is different. You can find out your disk's identifier using diskutil list

More information about the usage:

Usage:  diskutil eraseDisk format name [APM[Format]|MBR[Format]|GPT[Format]]
        MountPoint|DiskIdentifier|DeviceNode
Completely erase an existing whole disk.  All volumes on this disk 
will be destroyed.  Ownership of the affected disk is required.
Format is the specific file system name you want to erase it as (HFS+, etc.).
Name is the (new) volume name (subject to file system naming restrictions),
or can be specified as %noformat% to skip initialization (newfs).
You cannot erase the boot disk.
Example: diskutil eraseDisk JHFS+ UntitledUFS disk2
  • Thanks for the suggestion. I tried using diskutil before and now executed your recommendation. The error I get is: Started erase on disk2 Unmounting disk Error: -69825: Wiping volume data to prevent future accidental probing failed – Raphael Feb 18 '18 at 18:45
  • Did you try David's suggestion? – pixelomer Feb 18 '18 at 20:20
  • Yes I tried David's suggestion and it yields the same error: Error: -69825: Wiping volume data to prevent future accidental probing failed – Raphael Feb 18 '18 at 23:17
  • The problem remains no matter which option I choose. Any help would be highly appreciated. – Raphael Feb 22 '18 at 16:13
  • I will try to find other options. Before I edit my question for a macOS solution, you can try "gparted" from any linux distro (or even GParted live cd) or "diskpart" from Windows (Bootcamp). – pixelomer Feb 22 '18 at 16:29
0

The "wiping volume data to prevent future accidental probing failed" error message sometimes appears when the internal hard drive cable is experiencing problems. One way to confirm this would be to put the hard drive in an external drive enclosure and then attempt erasing it as an external drive. If it works, then you know the problem is not with the drive but with the cable.

If you don't have an enclosure to use the drive as an external drive you may be able to diagnose the issue by reseating the hard drive connection and putting electrical tape between the cable and metal computer parts it is touching. After reading tips suggesting this could solve the problem, I attempted this on a 13" MacBook Pro Mid 2010 experiencing the same error you described--and it temporarily fixed the problem for me. The symptoms started back up soon after so I still had to replace the cable, but it helped me diagnose the issue.

Note: Be sure to check warranty conditions before opening and working on a laptop yourself as doing so may void any warranty it is under.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .