I have this problem happening on a new 2011 Macbook Air with the latest version of Lion. When viewing emails, the text is coming through as odd characters that look like a capital A in a box (see image below). If I click Reply, and then convert the message to plain text, the entire text of the email displays fine. But in the message list, preview pane, and full message view, I get the odd characters any time I'm display rich text.

I've verified that my Mail.app is up to date, and in the Fonts & Colors preferences, the message font is set to 12pt Helvetica.

I can't say for certain, but I believe this started after I installed a trial of Microsoft Office for the Mac. The entire office suite (including Outlook, Word, Excel, everything) was installed.

enter image description here

5 Answers 5


We went digging through FontBook and found a bad copy of Georgia installed by Microsoft Office. After going through about a dozen duplicated font files, and removing the older versions of each, we restarted Mail.app. At this point everything is working perfectly.

  • Ya. Font problem. I've seen this before, and that's what it's been every time.
    – Harv
    Nov 18, 2011 at 4:43
  • Yeah, damn Microsoft Office screwed up some fonts by installing duplicates. Will those guys ever get it right? To fix the problem, open up "Font Book" and resolve all duplicates. Also, run "Validate Font" menu option to make sure all is kosher.
    – demisx
    Apr 23, 2015 at 4:28

The font selected in the Preferences, is used only for displaying messages what are haven't defined font. But for the rich-text formatted messages (html-messages) the mail.app will use the font what is defined in the message itself (or the default one) when such font is not installed or the message itself doesn't define the font.

So, if you got an

  • rich formatted message (e.g. with accented characters /e.g. utf-8/ ) and
  • in the message is defined the font (for example "Arial")
  • and you HAVE Arial font (but e.g. without unicode chacters)

you will get badly formatted message.

Try the following:

  • start Font Book.app
  • select preview->Custome
  • on the right side write write some text for waht you want test the font (you can use "character wiewer" to adding some text: e.g: "áéíóúöČĎÑ €¢ ШЩЪЭЮ ΣΦΞΩαβ אבג"
  • and select different fonts from the list on the left /start with Arial :)/

Fonts what are contains the tested characters will show ok = others will not. For example, the above text on my fontbook:

For my Arial font shows: enter image description here

but for another font shows clearly bad characters: enter image description here

When you find a bad font - try disable it - restart Mail.app and check the message again. If simple disable doesn't helps - maybe you will need clear the font cache - check this site for how to...

Warning: NEVER disable System fonts! Always check the (Preview->Font Info (CMD-I)). Never disable a font what show in the font-info Location in the /System/Library e.g.: Location /System/Library/Fonts/Helvetica.dfont

Another tip: try save the message in the "plain text" format, e.g. you will get "somefile.txt" (so, without any formatting) - and try open it in the TextEdit and try set different fonts...


Same problem as original poster. ie-bunches of As instead of words. First time on a mac so my response is educational. Purchase date May 2013. New macbook pro.

Find Font Book. How? Push with two fingers on the "Finder" icon. Select "Find". Then type in "Font Book" and a window will pop up.

click into the font section and two finger scroll down through the list of fonts. Some will have a little exclamation point inside a triangle to the right of the font name.

Select one that has the triangle and the window to the right will show an example of that font and below it there will be a statement saying there are duplicates for that font with two options. "Fix automatically" or "Fix Manually". Choose automatic. If it is greyed out, and won't respond to your selection, you have to expand the font to show all the different kinds (normal, bold, italics, etc.) and then select them individually and select fix automatically.

I had maybe 10 of these. Takes all of a minute. Close mail (red x in top left hand corner) and reopen and should be all fixed.

Hope this helps.


I was suffering the same thing. For me, it was a bad Arial font... Once removed, I restarted Apple Mail and all okay.

  • 3
    How did you identify the Arial font as the problem?
    – nohillside
    Apr 15, 2013 at 13:56

I just fixed the same problem.

First I had to identify what font was bad. I cut and pasted the "A squares" into word and it showed up normally as arial. I also played with the font in mail. Making it plain text showed it was fine. I made it Arial bold and it also showed fine, so normal arial was the culprit.

I then went to Font Book (it is in the applications folder for those new to the Mac) and selected Arial (only the plain, not the bold, italic, etc). I then used the menu command to disable it. I restarted mail. The message now showed up fine but with all the text shown as Arial Bold (regular arial was disabled). I then enabled the Arial font and everything then worked fine.

I am not sure why disabling and then re-enabling worked but it did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .