I have been using HomeKit on an iPhone 8 and 6s(both iOS 11.2.5) to control six Philips Hue bulbs through my 4th-gen Apple TV for the last few months with no issues.

Yesterday my Amazon Echo randomly stopped being able to control them so I reset the wifi settings(on the echo) and that solved the issue. At the same time my HomeKit also stopped working. All lights now give "no response" warnings.

I can still use the Philips Hue app on my iPhone to control the lights as well as through Alexa.

I am wondering why this may have happened and how to solve the issue.

I have tried restarting my Apple TV, but to no avail. I’m not sure what else to do or how to even go about resetting HomeKit. I can also still use the Apple TV as per normal so it is connected to the WiFi.

In response to answer regarding “reset HomeKit configuration” from privacy: enter image description here

1 Answer 1


Here's a solution from How To iSolve:

Step 1: Go to “Settings”.

Step 2: Open “Privacy” and tap on “HomeKit”.

Step 3: There tap on “Reset HomeKit Configuration”.

Step 4: Finally hit Confirmation Tab to finish the process.

enter image description here

However, I recommend reading the solution through, you might not even need to reset your HomeKit.

  • I don’t have that option for some reason(assumed it was gone on iOS 11, but that guide says otherwise). I just have an option to let Hue access HomeKit above the “Applications will appear here” message. The rest of the screen underneath that message is blank. Cheers though, I appreciate the help.
    – Andre
    Feb 19, 2018 at 16:44
  • I’ve added a screenshot to my original question there if it helps.
    – Andre
    Feb 19, 2018 at 16:48
  • 1
    That is a very good question, and I'm afraid I don't have an answer, as I can't replicate that behavior. Looking around online, it seems that people have had the "Reset HomeKit Configuration" option missing apparently randomly after updates long before iOS11. That leads me to assume it actually has nothing to do with the iOS version, but something else entirely. Maybe it depends on the account currently logged in, and which account was used for HomeKit/Hue setup?
    – Ilmari
    Feb 20, 2018 at 9:26
  • I don't see that option either. Wonder if this was changed in a later version of iOS.
    – tomh
    Aug 30, 2020 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .