I am using MacOS High Sierra 10.13.3 Macbook Air. The problem I am facing is that the internal touchpad and keyboard stop working as soon as I login. They also do not work in Safe mode. I have also tried to create another login account but the keyboard/trackpad fail to work there as well.

I have also tried SMC / PRAM reset multiple times and also reinstalled the OS from recovery mode, but again failure.

The only abnormalities that I have found are that 1) the multi touch kernel extension does not have a Plugins directory which is a different structure than all the other kext directories.

~ Fri Feb 16 20:19:11
$ ls /System/Library/Extensions/AppleUSBMultitouch.kext/Contents/ Info.plist MacOS/ _CodeSignature/ version.plist

and 2) there is no option to disable the trackpad in the accessibility preferences pane. accessibility_keyboard

Does anyone have any guesses as to what might be going on ?

  • No I enabled mouse keys after all this happened, to avoid having to switch between the mouse and keyboard.
    – Pushpendre
    Commented Feb 18, 2018 at 0:49
  • Sorry for the confusion, as I said my internal keyboard and trackpad stopped working. After they stopped working I plugged in some external USB keyboard and mouse. Those things worked fine.
    – Pushpendre
    Commented Feb 19, 2018 at 0:43
  • I had recently got a pair of BOSE QuietConnect bluetooth headphones. I guess maybe they could have caused this problem but it's impossible for me to say for sure.
    – Pushpendre
    Commented Feb 19, 2018 at 13:39
  • did you manage to fix this issue i have rthe same problem Commented May 31, 2018 at 1:28
  • @Chris Pepper try to change the configuration settings as shown below. You will have to use the terminal app.
    – Pushpendre
    Commented May 31, 2018 at 16:59

2 Answers 2


It seems that somehow the bits in the registry had gotten flipped. I tried two things: 1) I changed the configuration settings and 2) I removed all bluetooth daemons

## 1
defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad USBMouseStopsTrackpad 0
defaults write com.apple.AppleMultitouchTrackpad USBMouseStopsTrackpad 0

## 2
killall blued
launchctl unload /System/Library/LaunchDaemons/com.apple.bluetoothd.plist 
launchctl unload /System/Library/LaunchDaemons/com.apple.bluetoothaudiod.plist 
launchctl unload /System/Library/LaunchDaemons/com.apple.bluetoothReporter.plist 
kextcache -system-prelinked-kernel
sudo kextcache -system-prelinked-kernel

Based on the fact that the keyboard did not work even in safe mode, it seems that the first thing worked, since the keyboard and trackpad are working now after I restarted the computer.

  • I tried this, but it doesn't seem to work. Could you help me understand how these steps work internally in the operating system? The weird thing here, is that while the trackpad and keyboard do work before first login, it seems to be disabled afterwords. This is not an issue in neither Linux or Windows through bootcamp and otherwise.
    – Ole Aldric
    Commented Nov 24, 2021 at 2:04

hello guys if someone still has to suffer from the same problem I have the solution worked for me. You have to open your Mac:

1 - disconnect the battery

2 - remove the keyboard and mouse connectors

3 - make a small cleaning in the region and reconnect the connectors

4 - With the battery still disconnected, connect the charger and do the nvram (option + comand + P + R).

Hugs, I hope I have helped

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .