2

I recently bought a NAS (Synology DS218+) to help with backing up several Macs in my household using Time Machine. So far, each Mac has been backed up on individual hard drives.

I am trying to perform a backup of my internal SSD (500GB), as well as my my external HDD (around 1.1 TB of data). So, I am trying to backup 1.6TB at the moment via Time Machine as the initial backup.

My first attempt to get this to work, was by following Synology's instructions. I was able to discover the Time Machine folder on my NAS and TM started it's initial backup. After several GB of data transfer the backup stopped. No error message but not even near completion. Time Machine stated: 'Waiting to complete first backup'. Nothing happened after that. It transferred around 9GB of data but that was it. In case I did a mistake setting up the folder and user on my NAS, I reset the NAS and started from scratch. Same result... After a couple GB the NAS was again stuck and said 'Waiting to complete first backup'.

After some research I found a helpful Synology thread. I disabled HDD hibernation, disabled AFP. In a nutshell these are my current settings:

File share configuration:

  • I use BTRFS
  • "Advanced data integrity protection" is enabled
  • Encryption is disabled (for now - would like to have it but want to be able to get backups working first)

User configuration:

  • Standard user with a strong, random password.
  • Granted read/write access to Time machine file share and set quota of 3TB.

File services:

  • I have SMB enabled only - AFP is disabled.
  • Enabled Bonjour Service Discovery and Bonjour Time Machine broadcast via SMB.
  • Selected the Time Machine Folder

While all my first attempts were to get the initial TM backup to work over WIFI, I also tried connecting the NAS directly to my Mac. I enabled DHCP on my NAS, connected it via an ethernet cable to my Mac and started another backup. It got further than via wifi but again, it did not finish the backup. I let my Mac run over night, staying connected to my NAS, hoping the backup would finish... In the morning I was greeted by the same message again: 'Waiting to complete first backup'.

My Mac's power options are the following:

  • Prevent computer from sleeping automatically when display if off [ENABLED]
  • Put hard disk to sleep when possible [DISABLED]
  • Wake for network access [ENABLED]
  • Enable Power Nap while plugged into a power adapter [ENABLED]

Now, I am stuck too. I cannot think of what else I could possibly try to get Time Machine to backup to my NAS. This really has been some struggle so far... Looking forward to hear any thoughts and ideas :-)

Thank you very much in advance,

jrn

3

I've got a setup very similar to yours: a 480GB SSD and 1TB HD; both internal (718GB full backup reported in TM). I've been backing up to a DS213 successfully using AFP, and I'm setting up a DS418play using SMB. The Synology forums have conflicting posts regarding making TM work, including the one you reference. Another suggests TM has problems with DSM's SMB implementation, using SAMBA 4.4 (https://forum.synology.com/enu/viewtopic.php?f=64&t=139097). Nevertheless, I have both working for TM backups: AFP on the DS213 and SMB on DS418.

My working config seems the same as yours. Recommend you try these steps:

  1. But, check your DSM SBM settings: -> File Services -> SMB -> Advanced Settings

    • Max: SMB3; Min: SMB2
    • Transport Encryption: Auto
    • Enable Opportunistic Locking and SBM2 lease.
    • Enable SMB durable handles
  2. Are you connected via Gigabit Ethernet vs wifi? Do this at least for first backup.

  3. Reconnect to your NAS TM folder.

    • Turn TM OFF (stop auto backups)
    • Unmount the NAS TM drive
    • Restart Mac
    • Mount NAS TM drive: CMD-K, enter smb://NameOfNSA/tmFolderName -- This name/folder should be broadcast via Bonjour from NAS
    • You should get login window: enter NAS TM user credentials (I --I use a separate user for TM; Remember pwd in Keychain
    • Now Select this same "disk" in Time Machine prefs

If TM still won't complete, try..

  1. Start over with NAS TM share

    • Turn off TM
    • Unmount drive
    • Remove the TM backup from DSM Shared Folders
    • Create a new TM backup using settings above
    • Restart Mac and setup TM as above
  2. Try pruning down the size of your initial backup.

    • See if you can get a backup of just you SSD
    • Under TM Options, exclude your 1TB drive.
    • After successful backup completes, remove exclusion.
    • Backup again.

Even if this works, clone another backup of your drives. (TM is full of strange arcanery -- don't put all your eggs in one basket)

Update: I periodically see see an error saying "The networked backup disk does not support the required capabilities." In this case, reset the SMB Cache in DSM's SMB advanced settings. This will allow TM to back up again. For a while.

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – nohillside Mar 23 '18 at 15:43
  • Thank you for the pointers. It wasn't very complete. I think it's a little more helpful now. – Jonathan Dagle Apr 9 '18 at 21:56
  • Indeed, thanks for coming back and improving the answer! – nohillside Apr 10 '18 at 4:12
0

Check volume name for non-core-ASCII characters

I experienced the same problem as the OP, and followed @jonathan-dagle's answers precisely. It got it working once, but when I wanted to change the settings slightly, I never got it back up (pun semi-intended).

In my case, it seems the name of the Time Machine volume on the diskstation was the problem. The Swedish translation of Backups is Säkerhetskopior, and apparently the ä caused problems, because as soon as I changed the name to something without that character it worked again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .