0

This small white window often pops up and it's very annoying.

I'm using macOS Sierra 10.12.6

It may or may not be related to these questions: 1, 2

Annoying white pop-up window that appears randomly in macOS

The only way to get it to disappear is to click on the highlighted “1”.

But it doesn't stay gone. It appears at random intervals. I can't reproduce it consistently, but every time it appears it is when I press some combination of modifier keys and number keys.

After I click to make it go away it seems not to be able to return for several minutes.

The worst thing is that it seems to be interfering with my ability to use the Ctrl1 keyboard shortcut. Immediately after closing the window I regain my ability to use Ctrl1, but it's not permanent.

I have Japanese text input enabled, and at first I thought maybe it was a text input related window, but now I really have no idea.

Someone in an answer to another question pointed to Microsoft Office as the culprit. I have Office for Mac installed on this machine (not by my choosing), however closing those applications does not make the window disappear. There might be some background process related to Office causing it, but looking through Activity Monitor I can't guess what it might be.

Does anyone know what this is or how to get rid of it?

Thanks

  • 1
    Do you have XCode installed ? If so, you could use the Accessibility Inspector to see if you can at least determine which application owns the window. You could also examine the logs through Console to see what messages the system sends and is sent immediately prior to the window's manifestation, and then again when it closes. It might also log what process is intercepting your use of Ctrl+1 when you press it at various times. – CJK Feb 16 '18 at 9:51
  • A super quick check you could do from within Script Editor is to run an AppleScript command: tell application "System Events" to get every window of (every process whose class of windows contains window). This, of course, assumes that the white window is, in fact, a window and not some other entity. A slightly more generalised filter would be tell application "System Events" to get every UI element of (every process whose visible is true) whose role is not "AXMenuBar" – CJK Feb 16 '18 at 11:11
  • @CJK Thank you for the advice! I found out that it's the IMK Candidate Window (please see my work-in-progress answer). However, I still can't figure out how to prevent it from taking over my Ctrl key. I figured out that it uses Ctrl 1 and Ctrl 2 when some text is selected. – Mentalist Feb 16 '18 at 12:39
  • @CJK Never mind, I solved it! I just disabled the macOS native Japanese input system completely and installed Google IME instead. :-) Again, thanks for the tips - really helped me know where to look to get to the bottom of the problem. – Mentalist Feb 16 '18 at 12:56
1

It's the IMK Candidate Window.

Here's what Accessibility Inspector has revealed about it:

Using Accessibility Inspector to get info about the IMK Candidate Window

Why it has Ctrl 1 and Ctrl 2 assigned to it, and how to disable those shortcuts, I don't know.

But the solution that worked for me was to disable the native macOS input method for Japanese, and install the Google IME instead.

Here are my settings now:

Google IME settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .