15

I'm using macOS High Sierra (version 10.13.3) on a 27"-iMac and on a MacBook Pro.

Almost every time when I'm going to log in, I see various notification on the lock screen, even before I've entered my password. This means, that everybody, who passes by and moves the mouse or presses a key (or opens the lid on the MacBook), will see this notifications too, without being logged in. This is a security issue.

I know, that in the settings, I can deactivate Notifications on Lock Screen for every application. But there are 31 applications that are able to send notifications, and I don't want to click through all of them to deactivate this setting for every application separately.

I might oversee one of them, and when I install a new application, I might forget to deactivate this insecure behavior.

So I want a button where I can deactivate this insecure behavior globally, i.e. for all installed apps, and for all apps that might be installed later.

Is there such a button? If there is one: Where is it?

  • even if there were no such button, you can use the information >here to create two scripts to do it – Gio Valerio Feb 17 '18 at 21:22
  • 1
    @GioValerio: I don't want to disable the entire notification system completely. I like this system, and I often need this notifications. But I only need them when I am logged in. I'm just looking for an easy and reliable way to get rid of the notifications on the Lock Screen where everybody can see them, even when nobody is logged in. – Hubert Schölnast Feb 17 '18 at 22:39
  • I understood it. The information in the page I referenced explains how to disable and reenable the notifications system, by using the launchctl command. That could be combined with an utilitiy like >Hammerspoon to execute those commands when the lock screen is activated or disactivated – Gio Valerio Feb 18 '18 at 0:24
  • 2
    @GioValerio: But this hack doesn't meet exactly the definition of "a button". I want an easy and reliable solution, not a complicated hack that might fail after the next OS update. – Hubert Schölnast Feb 18 '18 at 8:58
  • 2
    This seems to be one overlooked security issue, as by default new applications set "Show notification preview" to always instead of when unlocked. I have been looking as well how to set default to, but did not find solution. There is also StackOverflow question related to this issue here: stackoverflow.com/questions/52661430/… – Maksim Luzik Mar 18 at 12:07

You must log in to answer this question.

Browse other questions tagged .