1

Touchbar breaks my external keyboard, and the option to use all fn keys as fn keys is gone. Is there a way to do so anyway? For me the whole touchbar thing is completely useless, and I'd prefer only having it while I hold the fn key, like it works when I add a single app in the settings

Sierra 10.12, 2017 model

  • Didn't realise you couldn't do that anymore. I don't have a Touch Bar MBP though so I can't really help. – Andre Feb 14 '18 at 17:27
  • 1
    here apple.stackexchange.com/questions/262828/… they suggest to use the karabiner-elements app... doesn't it work for you? – Gio Valerio Feb 15 '18 at 0:07
  • @GioValerio I was facing issues with Karabiner - completely broken fn key. So for me it's also not the best option (as I don't have an eject key but need sleep/lock hotkey). However, it's the closest solution I see at this point – mr. Nutscracker Feb 16 '18 at 13:38
  • Have you tried Touch bar shows F1, F2, etc. Keys in Keyboard settings? – JBallin Feb 19 '18 at 18:35
  • @JBallin UPD This option is only available for "Press Fn key to". I want it to be active by default. – mr. Nutscracker Feb 21 '18 at 11:29
1

If you go to Settings > Keyboard, in the Keyboard pane, the box "Touch Bar shows" select "F1, F2, etc. Keys" as the option.

The touch bar will now just show Fn keys as if it was a normal keyboard. (They will dim and appear black sometimes.)

Then, you can change the setting directly below, "Press Fn key to" and select "Expand Control Strip" or "Show App Controls". This will fulfill your request to "only have it while I hold the fn key."

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .