7

I've noticed recently that even though my iPhone (running iOS 11.2.5) has "do not disturb" mode on at night, WhatsApp voice calls go through as usual. So far, the only solution I could come up with is turning vibrations off in the sounds settings. Is there a better way to handle this situation? If not, who should I contact in this case? Apple or WhatsApp?

Thank you!

  • 1
    Go to settings->do not disturb-> then check all the settings... – Harcker Feb 13 '18 at 11:31
  • 1
    @Harcker Apologies, but I couldn’t find any helpful setting in there. Which one did you have in mind? – user1337 Feb 13 '18 at 11:41
  • 1
    The ones to let call through (“allow calls from” and “repeating calls”, (I don’t have the correct English names)) – Harcker Feb 13 '18 at 11:43
  • This is definitely a regression. It used to work for sure. And actually the Apple discussion linked on the agreed answer confirms it’s a bug. – Goul Apr 30 at 23:47
1

This is intended behaviour. Do Not Disturb only enables Apple's features like phone and messages. It does not affect third-party applications.

From this Apple Discussion:

It has nothing to do with Apple's software. Do not disturb only affects Apple's core iOS features - the telephone app, the messaging app and iOS notifications service. It does not interact with or affect third party apps.

If you want Whatsapp to implement the feature you need to contact them:

If you want WhatsApp to implement something similar, then you need to suggest it to the WhatsApp developers. Or, close WhatsApp at night, and disable it in background app refresh in settings.

To provide a similar setting on Whatsapp you can close it at the desired time and turn on background app refresh which will prevent it from updating and receiving messages.

To turn off background app refresh

Go to Settings -> General -> Background app refresh and turn of Whatsapp.

To completely turn all apps of from refreshing click at the top where it says background app refresh and click off.

  • This is poor from Apple to be honest, they block notifications from 3rd party apps but not calls? Seems like a disjointed user experience :( this Apple page makes no mention of it not working under odd edge cases: support.apple.com/en-gb/HT204321 – peteski Feb 12 at 18:37
  • WhatsApp on Android does not have this problem FWIW – Silas S. Brown Aug 19 at 10:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .