3

I seem to only be able to AirDrop to/from one of my Apple devices to another if one of them is signed out of iCloud. I have all my devices (iPhone X, 2017 iMac High Sierra, 2017 MacBook Air High Sierra) all signed in to my iCloud account (the same account). The devices cannot see each other in AirDrop unless I sign one of them out of iCloud.

For example, if I sign my MacBook Air out of iCloud, then my MacBook Air shows in my iMac's AirDrop and I can freely transfer files to it. Once I sign back into iCloud, it goes away.

Note: I can see and AirDrop to any of my colleagues' devices just fine across all of my devices. I just can't send to any of my own devices unless I sign out of iCloud.

I've tried all of the standard AirDrop troubleshooting (Making sure Bluetooth is on, same Wifi, update all devices, restart, etc).

  • 1
    Try rebooting the devices and disable do not disturb on ALL devices, it may solve your problem – Harcker Feb 13 '18 at 11:47
  • Tried that already. No dice :( – Dan Feb 13 '18 at 15:54
  • Also disabling do not disturb? – Harcker Feb 13 '18 at 17:23
  • Yes do not disturb is disabled on all my devices – Dan Feb 13 '18 at 18:24
  • 1
    I'm having this issue right now. Has a solution been found? – Da Fingaz May 21 '18 at 22:44
1

Is airdrop set to everyone, or to contacts only? If it’s set to contacts, do both devices have Contacts checked in the icloud account preferences? Is your own card defined in your icloud contacts?

In addition, there is a very thorough list of obscure Airdrop troubleshooting tips at: http://www.idownloadblog.com/2016/02/20/airdrop-troubleshooting-tips-2/

Might be worth a look. Hope you find your answer!

  • I had tried everything in this article before posting here :/ – Dan Feb 22 '18 at 16:19
1

I finally found a solution that worked for me. This seems unrelated but it definitely was my issue. It also fixed my issue with Apple Watch not being able to unlock my Mac. Below is what worked for me.

On your Mac:

  1. Open up Messages App
  2. Go to Messages > Preferences
  3. Select Accounts Tab
  4. Select Blocked Tab
  5. Locate and delete any instances of your own phone number and/or email addresses
  6. Close and wait ~5 minutes for iCloud to sync the changes across all your devices

On IOS:

  1. Go to Settings -> Messages -> Blocked
  2. Same as step 5 and 6 above

After performing those steps Airdrop worked perfectly across all devices and, as a bonus, I was able to unlock my Mac with my Apple Watch again (I was previously getting "your mac was unable to communicate with your apple watch" error / "IDS device not cloud paired").

Hope this helps others!

  • 1
    Because of spam callers spoofing my number, I blocked my own number last week. Airdrop stopped working around that time as well. I didn't add those two events together. This solution worked perfectly. Still curious though, why blocking my phone number blocks airdrop messages! – Sidmeister Feb 7 at 3:37

You must log in to answer this question.

protected by Community Sep 12 '18 at 21:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .