enter image description here

I tried searching what error -10810 is but nothing came up on Google. Any idea on how to fix this or go around this?

  • Does Safari open okay if just opening it from Finder? Have you tried running First Aid on the e.g. Macintosh HD in Disk Utility? Feb 12, 2018 at 22:36
  • I'd also try reseting the Launch Services Database from Terminal with the following command: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user Feb 12, 2018 at 22:50
  • Possibly related: apple.stackexchange.com/questions/181026/…
    – Zajn
    Feb 12, 2018 at 23:27
  • If you Google "error -10810", with quote marks, you get results, fyi. Feb 12, 2018 at 23:43
  • IIRC, I have also seen this error code when the users in the terminal and graphical sessions differed. I too failed to find anything in my online search. Feb 13, 2018 at 16:01

1 Answer 1


When opening an application with the open command, you should use the -a option, e.g:

open -a "Safari"

From the man page for the open command:

-a application
    Specifies the application to use for opening the file

Note: If you use the -a option, you typically do not need to specify the pathname or even use the .app extension. Just the format as in the example shown above should work.

In Terminal, the executable permission (and others) output of:

ls -l /Applications/Safari.app/Contents/MacOS/Safari

Should be:


If not, then in Terminal, run the following command:

sudo chmod 0755 /Applications/Safari.app/Contents/MacOS/Safari

This will ensure the proper permissions on the Safari executable and should stop you from getting the error you've got.

  • same error occurs Feb 12, 2018 at 21:56
  • If there's a permissions problem, "Fix Permissions" in Disk Utility should deal with it.
    – Barmar
    Feb 13, 2018 at 4:43
  • @Barmar, Fix Permissions has been removed from Disk Utility for some time now, so it depends on what version of the OS the OP is running. That said, there is nothing wrong with manually checking it in order to eliminate it as the cause of the issue and if so manually applying the proper permissions. Feb 13, 2018 at 9:53
  • lol I bet they removed it because users were using it any time they had a problem, but permissions were rarely the cause. Now this user needs it and it's not there. :)
    – Barmar
    Feb 13, 2018 at 9:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .