1

I'm using Remote Desktop app on the full screen and when I get my mouse too close to the bottom of the screen (in orders to interact with remote system), the Dock is shown.

macOS Dock, show/hide

The mouse pointer (annotated below) is not even close to the Dock edge or icons and the bar is already showing up.

macOS Dock, show/hide

So there is no way I can access the bottom icons on the remote machine.

How do I change Dock behaviour, so it's not so aggressive when it comes to appearing? Or disable it in the full-screen mode completely?

3

System Preferences application allows you to change the behavior of the Dock. The Dock preferences pane is shown below.

99

I would suggest moving the dock to the left or right side of the screen.

  • Pretty weird, but when I've set it to the right, it's showing up (on the right side), but only when I move my mouse to the bottom, not to the right. Sounds like a bug. – kenorb Feb 12 '18 at 13:49
  • @kenorb: What version of macOS are you using? What version of Microsoft Remote Desktop? I am using macOS 10.13.3 and Microsoft Remote Desktop 8.0.43. I tested and I am not having the problem you describe. – David Anderson Feb 12 '18 at 14:03
  • I'm on macOS 10.12.6 with MRD v8.0.5. From my experience, my system always behaves differently. I'm planning to install High Sierra over the weekend anyway on the new SSD. – kenorb Feb 12 '18 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .