I just bought a 21.5 inch iMac (latest macOS), I was using a macbook and got used to the trackpad and multitouch gestures, so I bought one (Magic trackpad 2) for desktop stuff as well. Its my third day with it and the pinch to zoom multitouch gesture stops working for a while, and then if I restart the computer or leave it, when it comes back from sleep It may be working fine. I've tested in all possible applications, such as:

  • Keynote
  • Photoshop
  • Preview

And nothing, the other multitouch gestures such as the one for scrolling, show apps, dashboards, three finger move, they all work as usual, I have to restart the computer to see if the pinch zoom will work. Im really upset because my macbook is from 2009 with OSX Yosemite and all the trackpad gestures work like a charm, never had this type of issue.

I would be happy if someone knows a solution for this. Thanks.

  • What steps have you tried to resolve this issue? – Jake3231 Mar 10 '18 at 19:53
  • When I detect that the gesture is not working properly, I put to sleep 30 seconds the computer and wake it up. That usually works, or even restarting it. Thats the only thing I've done. – Karlo A. López Mar 10 '18 at 20:20
  • Thanks. Have you tried an NVRAM reset on your Mac? Even booting into Safe Mode then rebooting could be helpful. – Jake3231 Mar 10 '18 at 21:56
  • A similar issue is discussed here. You can try to see if that helps. – Nimesh Neema Mar 15 '18 at 11:54

You must log in to answer this question.

Browse other questions tagged .