I have few media files in my Mac which I want to stream on my Android phone. I have enabled File Sharing and enabled both smb and afp protocol. When I check in VLC for Android app, I can see my Mac's name there. However when I try to connect it, it shows me a login prompt asking me to enter username and password.

I tried my Mac's only username and password, but it didn't do anything. The username have spaces in it, so I tried some combinations (such as all lowercase, no spaces etc.), to no avail.
For eg. If my username on my mac is Abc Xyz, I tried Abc Xyz, Abc%20Xyz, abcxyz, AbcXyz etc. But it showed me empty directories.

So is there any way I can make that login prompt work? I even tried with giving Everyone access to the shared folders, but it still didn't work. By not working, I mean, the VLC displayed error The directory is empty or a login prompt again.

PS: I am on macOS Sierra (10.12.6) and the user have admin access.

2 Answers 2


You can just enable guests to access shared folders. Go to Users and Groups and give access to Guests to Shared folders/Sharing.

  • thank you, enabling guest user and allowing access for guest to shared folders works Commented Jun 4, 2019 at 19:40


On most *nix systems Android included to login with a a user name which has a space you'd escape the space with a \, ie. John\ Doe The \ will allow the OS / shell to know that a special character, ie. a space ␣ or another special character will be next, thus the escaping with a \.

So I was curious about how this could be done this afternoon as well, so I spent about an hour to get things setup, and I now have a working solution.

First off, my situation is a little different from yours, but essential the same. Instead of having an Android phone, the wifey 👰 has an Amazon Fire TV Stick. I have some vidoes on my MBP that I'd like to watch on our TV with the Fire Stick. The Fire Stick uses Android OS as well, and also supports VLC with no side loading BS 💩.

I proceed to download and install VLC on the fire stick, and it appears to run fine. 👍 There is a pretty accessible menu for accessing local network shares.

Now, comes the fun part of setting up the Network Share, ie. my MBP MacBook Pro.

I have all my local videos files stored in $HOME/Movies on my macOS box, so I could make that folder accessible by setting it up as a share using SMB or AFP which is "kind of" what I did but not really.


  • Create a regular user on the system and give it read access to your $HOME/Movies directory.

Expanded procedure

  1. Create a new user on macOS, I chose the username media.

    a. From Apple Menu select System Preferences...

    b. From the System Preferences dialog select Users & Groups

    c. Click the ➕ within Users & Groups, and create a Standard User.

Create a new user.

  1. Create a new group within the same Users & Groups dialog, I chose to name the newly created group media as well.

Create a new group

  1. Add the user which the video's belongs to, ie. in my case that would be capin. And also add the media user to the newly created group as well.

Adding Users to a Group

  1. Next turn on File Sharing from System Preferences within the Sharing button.

Enabling File Sharing

  1. Set the Shared Folders and Users within Sharing System Preferences with the users and permissions you want for your shared folder, and remove any unused shares if so desired.

Setting Permissions for the Share

  1. SMB settings

A couple of notes, I was unable to get AFP to work properly, but I did have luck 🍀 getting SMB working. And, another thing you'll have to input the username & password for the media account you setup.

IMHO I can't help but think creating a separate user to access media shares is a much better solution that using your daily driver 🚗 account for obvious security reasons.

cheers 🍻

  • Thanks for the solution. I have tried this, but everytime I enter the password, it goes back to the list of network screen. If I enter wrong password it asks me again. I have even kept the username media with a simple password.
    – noob
    Commented Mar 7, 2018 at 17:38
  • @noob it was rather late in the evening when I wrote that answer yesterday 🥃 but glossing over what I wrote yesterday I think I forgot one important step to getting this working. You'll need to properly set the permissions of your media folder / directory. Can you open the Terminal.app and do a ls -lah of the directory which contains your media. ie. for me it would like ls -lah /Users/capin/Movies and then post the output somewhere, preferably at gist.github.com or ghostbin.com
    – ipatch
    Commented Mar 7, 2018 at 20:15
  • This is the best answer
    – JFC
    Commented Feb 1, 2021 at 7:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .