3

I'm running Linux Mint on Virtual Box (.vdi on my internal SSD) on my rMBP (macOS High Sierra).

While I haven't pinned down a pattern, I think it breaks every time my computer wakes up from sleep. So, I assume its something to do with putting the SSD to some sleep-state which breaks Mint.

What setting can I enable/disable to keep this from happening?

2

This is expected behavior.

Your VM is not going to continue to run when your Mac goes to sleep. In this case, your VirtualBox will attempt to save the state of the machine. I have found FreeBSD to be forgiving in these cases, but Linux (Ubuntu) has never liked it when the Mac went to sleep and VB attempted to save the state.

The most effective solution is to disable sleep when your VM is running.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .