2

In trying to resize a bootcamp drive, I managed to get myself in a lot of trouble. I've successfully managed to get my computer running again, but now I've lost some HD space and I can't resize or remove any of the partitions except for the bootcamp volume. Any help is very much appreciated. I am willing to wipe the entire drive and start over with my TM backup, but I can't seem to get the Fusion drive to even allow reformat while in Recovery Mode.

iMac:~ hellman$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Mac HD                  121.0 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *3.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage Mac HD                  2.1 TB     disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
   4:       Microsoft Basic Data BOOTCAMP                99.0 GB    disk1s4
   5:          Apple_CoreStorage                         402.0 GB   disk1s5
   6:                 Apple_Boot                         134.2 MB   disk1s6
   7:                  Apple_HFS Hell Baby               398.8 GB   disk1s7
   8:                 Apple_Boot Recovery HD             650.0 MB   disk1s8

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +2.2 TB     disk2
                                 Logical Volume on disk0s2, disk1s2
                                 B7F7A5D5-EF16-4221-9630-CF4C93618955
                                 Unencrypted Fusion Drive

iMac:~ hellman$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group D1C81059-65FF-4528-B862-9C93152602EC
    =========================================================
    Name:         Mac HD
    Status:       Online
    Size:         2219635531776 B (2.2 TB)
    Free Space:   16384 B (16.4 KB)
    |
    +-< Physical Volume 82570857-4FBF-4E5F-ACEA-043B49F9317A
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     120988852224 B (121.0 GB)
    |
    +-< Physical Volume BE84AD9C-B121-4900-827B-F882607AEFF2
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     2098646679552 B (2.1 TB)
    |
    +-> Logical Volume Family CA8476E4-5B44-48C4-BC88-10B68F99FC04
        ----------------------------------------------------------
        Encryption Type:         None
        |
        +-> Logical Volume B7F7A5D5-EF16-4221-9630-CF4C93618955
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          2213780258816 B (2.2 TB)
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
            LVG Type:              Fusion, Sparse
5
  • Sorry about the formatting, I'm new to this: Feb 10, 2018 at 16:52
  • 1
    best thing would be to just post it straight, as is. That will allow someone else to reformat it with a single key command ;-) Alternatively, if you select all the 'code' text, then ctrl/k will do the job. It's just a lot harder to do if you've already tried to make it play ball & it won't.
    – Tetsujin
    Feb 10, 2018 at 17:15
  • Nice one! Welcome to Ask Different :)
    – Tetsujin
    Feb 10, 2018 at 17:30
  • 1
    What is your question? Did you boot to build-in or internet macOS Recovery? See Mac startup key combinations for options. Feb 10, 2018 at 19:49
  • 1
    I'd like to reclaim the space on my drive. Both disk1s5 and disk1s7 volumes can't be removed or resized. I'd like to reclaim those disks to a single partition. I'm willing also to get rid of the BootCamp drive if necessary. Similarly, I'm willing to wipe the entire Fusion drive and start over, but Disk Utility in recovery mode won't let me reformat it, and I don't know what I'm doing in diskutil to accomplish that. Feb 10, 2018 at 20:57

1 Answer 1

3

Solved: I used an Apple support link that gave me keystrokes in diskutil to re-map the Fusion Drive in Terminal. I was able to reclaim all disk space and I'm reinstalling from my Time Machine back up now:

https://support.apple.com/en-us/HT207584

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .