3

I have a WD "My Passport" 1TB external hard drive. It isn't recognized by my Macbook Pro (retina, 2013) or a friend's very similar model, but it works with every other machine I've tried, including two Linux netbooks and an older iMac.

Sometimes, it mounts after multiple tries unplugging and replugging the cable. Usually, the hard drive spins up and lights its status LED, but it is not mounted or recognized by Disk Utility or the diskutil list command.

This question seems to describe a similar issue, but their drive doesn't connect every few dozen attempts like mine does.

What could be causing this issue?

Edit: When the drive is plugged in, this is output to dmesg:

Starting poll type 4
Restarting poll type 4
Command 0x2 completed. inCount: 2 data:0x5Command 0x1 completed. inCount: 2 data:0x1001Command 0x16 completed. inCount: 2 data:0x40e0Command 0xa completed. inCount: 2 data:0x0Command 0xb completed. inCount: 2 data:0x0Command 0x12 completed. inCount: 2 data:0xffffCommand 0x13 completed. inCount: 2 data:0xffffCommand 0xf completed. inCount: 2 data:0x1b6eCommand 0x10 completed. inCount: 2 data:0x1bacSmartBattery: finished polling type 4
kxld[net.lundman.spl]: In interface net.lundman.kernel.dependencies.28 of __kernel__, couldn't find symbol _panicstr

kxld[net.lundman.spl]: The following symbols are unresolved for this kext:
kxld[net.lundman.spl]:  _panicstr
Can't load kext net.lundman.spl - link failed.
Failed to load executable for kext net.lundman.spl.
Kext net.lundman.spl failed to load (0xdc008016).
 Dependency net.lundman.spl of kext net.lundman.zfs failed to load.
Kext net.lundman.zfs failed to load (0xdc008015).
Failed to load kext net.lundman.zfs (error 0xdc008015).
Kext load request buffer from user space still retained by a kext; probable memory leak.

Edit 2: That output is still displayed when connecting a working flash drive, along with other stuff about USB media and about filesystems. It is not unique to the drive in this question, but it is the only thing outputted when this drive is connected.

Edit 3: So I did in fact have openZFS installed, at least partially. (No idea how or why). After running their uninstall script, nothing is output when this drive is plugged in at all.

Edit 4: Connecting with an ordinary MicroUSB cable instead of a USB 3 cable works every time. I realized that every other device I tested it on that worked didn't support USB 3. I just tested it with a Windows device that supports USB 3, and while it is better than the Mac, it still has a problem recognizing the drive. Interestingly, the Windows computer shows the drive as not supporting USB 3.0.

  • 2
    Does the problem exist with a different external drive? You could have a bad port. Also, use the command sudo dmesg to see if the drive is recognized by the OS. – Allan Feb 9 '18 at 17:37
  • 1
    @Allan Both USB ports work with a flash drive. – whoKnows Feb 9 '18 at 17:59
  • 1
    Do you have some sort of ZFS kext (driver) installed? Try booting in Safe Mode (hold Shift while booting) and see if the problem persists. – Allan Feb 9 '18 at 18:15
  • 3
    @MelvinJefferson The disk itself isn't recognized by the computer. Formatting wouldn't make a difference. – whoKnows Feb 9 '18 at 18:35
  • 2
    @MelvinJefferson - what would power management or what in NVRAM would specifically address this issue? SMC & NVRAM reset is way overused. And if the OS can't see the device, how exactly is an application supposed to see it? – Allan Feb 9 '18 at 18:44
2

I had the same issue with a WD Elements 2.5" 2TB disk on my retian macbook with macOS High Sierra.

My assumption is that the disk "fell" off the USB bus and macOS instead of gracefully retrying is just giving up.

In my case the disk worked for an hour or two, but then I got the error that I should eject Disks before unplugging them and the errors in the dmesg.

I guess this is a combination of macOS being not very forgiving and the WD on-disk USB controllers being a little wonky.

I was using a USB3 hub between the macbook and the disk, so maybe that was the source of wonkyness.

I have no ZFS drivers installed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .