1

This question already has an answer here:

I’m new to MacOS world.

By accident I deleted the admin partition (Directory). Every time when I want to install a programme, the system ask me for the admin login. I enter the login but it is not accepted.

I tried yesterday to reinstall a new OS via recovery to get everything new. The reinstallation was successful (it took more than 2 hours ), but as started the system I found that all my data is still there and I still have the same admin login problem and the same username.

I have tried resetpassword via Recovery but I get a window which says there is user account available

my question is:

How can i fix this problem quickly?

Any advice will be apreciated

marked as duplicate by klanomath, fsb, Allan, grg Feb 9 '18 at 18:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    There's no "admin" partition; are you referring to a particular folder? The quickest and easiest way to solve this is to reinstall just as you did before, but prior to doing so, wipe the drive using Disk Utilities (top menu bar of the installer) – Allan Feb 9 '18 at 14:04
  • yes my data is still there. i still have a user to log in but it is not an admin user. i cant install any programm because i will be asked for an admin login which i dont know. how to delete this password. – AhmyOhlin Feb 9 '18 at 14:18
  • Use the rm .../.AppleSetupDone work-around: How can I reset a Mac's password from Single User Mode? (use the "third way"!) – klanomath Feb 9 '18 at 15:00

Browse other questions tagged .