3

I had to reinstall macOS recently, and ever since, I am not able to back up. After a Prepare phase, it gets to backing up some 5-6 Gigabytes (if I am lucky), then it stops ("Stopping..." as seen in preferences). It was working perfectly before.

  • I am using High Sierra 10.13.3.
  • I am on APFS
  • I am trying to backup to a Time Capsule (firmware version 7.6.9) over wi-fi
  • I am using a MacBook Air from 2012
  • I have tried restarting Time Capsule (which triggers an fsck)
  • I have tried to reuse same backup as before, or create an entirely new backup
  • I am trying to use an encrypted backup (backing up without encryption is not an option for me)
  • I have tried excluding system folders from backup so that only /Users remains

As I said, there are no visible errors. In the system log I see some messages, although I am not sure what to do with them (there is no problem reading mentioned file, and I am not sure why it wants to copy to (null), maybe it has lost connection or something, but the situation is not clear).

Error: (-36) SrcErr:YES Copying /Volumes/com.apple.TimeMachine.localsnapshots/Backups.backupdb/R'lyeh/2018-02-08-110642/R'lyeh/Users/zsszatmari/projects/servehome/node_modules/babel-preset-es2015/node_modules/babel-plugin-transform-es2015-classes/node_modules/babel-template/node_modules/lodash/function/rearg.js to (null)
Failed to unmount disk mounted at '/Volumes/com.apple.TimeMachine.localsnapshots/Backups.backupdb/R'lyeh/2018-02-08-094426/R'lyeh', error: {
    Action = Unmount;
    Target = "file:///Volumes/com.apple.TimeMachine.localsnapshots/Backups.backupdb/R'lyeh/2018-02-08-094426/R'lyeh";
}
Failed to delete APFS snapshot with name 'com.apple.TimeMachine.2018-02-08-094426' on volume '/', error: Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"

Also:

$ log show --predicate 'subsystem == "com.apple.TimeMachine"' --info | grep 'Backup failed'
2018-02-07 09:45:49.644125+0100 0x8da43    Error       0x41fd0              10549  14   backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed because a backup source disk was ejected or disconnected unexpectedly!
2018-02-07 09:45:49.678109+0100 0x8da43    Error       0x41fd0              10549  14   backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed with error 37: 37
2018-02-07 10:01:14.923986+0100 0x95f8f    Error       0x450cc              11759  14   backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed with error 50: 50
2018-02-07 10:37:38.571642+0100 0xa06e0    Error       0x0                  12807  14   backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed with error 19: The backup disk could not be resolved, or there was a problem mounting it.
2018-02-07 13:26:23.305069+0100 0xa5320    Error       0x0                  13003  14   backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed with error 18: The backup disk could not be found.

I am not sure why would it think that the backup source (the boot drive) is ejected, or why would there be a problem mounting the backup drive.

Thank You.

1

Problem seems to be solved, I am not sure how.

  • I deleted the erroneus file, but I don't see why it would cause problem in the first place
  • By a friend's suggestion I've moved physically closer to the Time Capsule, maybe it is getting older and the wifi connection is weaker
  • I've deleted a volume from boot APFS container (but it wasn't mounted anyway)

I am still somewhat puzzled, but maybe someone coming by with same symptoms can make use of any of these.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .