0

I am using iTerm2 3.0.15 beta on Sierra. I have had shell integration installed since many months ago. At some point, shell integration stopped working. (I'm not very observant; I just noticed it at some point. I'd been away for a while, too.) What I mean when I say it stopped working is that command history, recent directories, etc. sections of the Toolbelt are empty. Also, there are no mark indicators before the bash prompt.

I've been looking for a solution off and on for some weeks. I've tried manually sourcing $HOME/.iterm2_shell_integration.bash to make sure it was sourced and that it wasn't getting clobbered by something else in my setup. Just today, I upgraded to 3.1.6 beta 2, but shell integration is still not working.

Nothing has worked and I'm at a loss for where else to look for problems.

  • just out of curiosity, how could you tell it wasn't working? Did you try to display an image?? – jmh Sep 4 '18 at 15:00
1

Had the same problem. Running this command fixed the problem to me:

curl -L https://iterm2.com/misc/install_shell_integration.sh | bash

It will re-install shell integration. You can found more details on the following link.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .