2

I bought an Insignia USB 3.0 to Gigabit Ethernet Adapter with my early 2015 MacBook Pro. I don't have a CD drive, so I downloaded the driver from their website. Now, when I try to go to my network preferences, it takes about 5 minutes to load. Then it g off. I was trying to find how to uninstall the drivers but cannot find them. If it is helpful I can make a pastebin of my syslog.

I maybe want to know how to uninstall the driver for this so I can at least use my wifi.

  • 1
    Welcome to Ask Different! :) Are you saying that your Wi-Fi no longer works because of this driver? If so, does this happen even when the Ethernet Adapter isn't plugged in? Also, have you tried booting your MBP in Safe Mode and testing to see if you're still having problems while in Safe Mode? For more info on Safe Mode refer to Use safe mode to isolate issues with your Mac. – Monomeeth Feb 7 '18 at 23:29
  • I fixed it, I found the most recent drivers on a different website. Oddly, insignia didn't have the most recent drivers and I found then elsewhere – TheStrangeQuark Feb 7 '18 at 23:31
  • That's great you fixed it. :) Can I suggest you add that as an answer to your own question and also include the link? It's bound to help others. – Monomeeth Feb 7 '18 at 23:33
1

It turns out I was using an old driver that was given on Insignia's website. I found that it is a Realtek adapter and the most updated driver is found here: http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=56&Level=5&Conn=4&DownTypeID=3&GetDown=false. This driver fixed all my problems.

0

or

Windows & Mac - Insignia NS-PU98505 Drivers

https://www.file-upload.com/si27gargwxm9

  • 1
    Is there an official source for this or could this be malware? – bmike Aug 22 '18 at 2:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .