By default, when I close the lid of my macbook, the external display becomes the primary. It is annoying because I have to plug out the cable and charger to turn it off but I'd like that whenever I close the lid of my macbook, it puts the macbook to sleep and turns off external display? Is it possible?

6 Answers 6


As macOS doesn't provide a way to shutdown all screens by closing the laptop lead, which is a shame, you can put the laptop in sleep mode and also set security parameter to lock it immediately when it goes to sleep so you can leave once the screen is black.

If you have a MacBook with Touch Bar, you can also add the sleep icon to it : enter image description here

I put it on the left to be sure not to touch it when i hit the fingerprint sensor or the delete key...

To modify the touch bar, go to system preferences/keyboard and you will find a "customise touchbar" on the bottom right corner.


Putting the MacBook to sleep by using the mouse to select the "apple icon" in the (drop down) menu in Finder, and then select "Sleep" should turn off the external display.

I use a MacBook with a MiniDisplay Port and USB monitors. I have the same behaviour as you when I close the MacBook. But when I put the MacBook to sleep via the drop down menu, all the monitors turn off.

  • 1
    oh! that's an improvement. however, i was hoping tho that closing that there would be a setting to do it by closing the lid!
    – Abby
    Feb 7, 2018 at 21:01
  • 2
    You can also press Ctrl-Power button right before you close the lid. It will put it to sleep immediately, then you close the lid.
    – Allan
    Feb 9, 2018 at 1:39

You can lock the screen and then cancel login window.


Lock screen: ⌘ + ⌃ + Q

Cancel: Esc


Not really a solution, but if you just want a quick way to turn off your screens, closest thing I've found is using "Hot Corners" inside your screen saver settings.

System Settings > Desktop & Screen Saver > Hot Corners

Assign bottom left corner to "Put display to sleep".

Moving your mouse to that corner will make your mac sleep and turn off monitors.


If you have an external keyboard connected, you can try pressing CMD-Brightness Up. If you don't have an external keyboard connected, you can press the power button on your display (if it has one). If those don't work you'll have to: Unplug the HDMI/Thunderbolt cable going to the display from your Mac. Unplug the power adapter from your Mac. Shut down your Mac. Change the input on your display (if available).


Command+brightness DOWN is what you need to press.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .